My first issue with Windows 7:(

#1
Im new here,so hello everyone. Ive just built a new PC and come back to Windows *im using W7 Home Premium* from using Ubuntu Linux and Nvidia. So quite a switch. Ive got an Asus 22" VW246.I just had my computer built *specs down below* by a custom PC company,ive contacted them and am awaiting a response,but my issue is that i dont think its recognizing my ATI Radeon HD5770.Under Display adapters in Device Manager it only lists Standard VGA Graphics Adapter.Theres no caution symbol or alerts,either. Ive tried searching for new hardware,that doesnt work. When i tried to install the driver disk that came with the PC,it says it installs correctly,and it needs to reboot.When it reboots after it says Starting Windows it shows the windows logo,and then i get a blank screen.Sometimes my mouse is present and movable. Sometimes it isnt,either way,blank screen. I have to start in safe mode and recover my PC.IVe also tried slightly over drivers,and the same thing happens. When i try to play World of Warcraft i get an error that says Suitable Display Device not found.Exiting Program. I noticed in DXDiag is says Not Available for DirectDraw,Direct 3D Accel. and AGP texture Accel.Im sure this is the issue,it must not recognize the card,so it doesnt use it? Im not sure.Ive been googling all day and i cant seem to figure this out. Any help would be appreciated,ive attached my DXdiag file. my specs are below.

AMD Phenom ii x4 965 BE
Asus Crossfire iii Motherboard
4GB (2x2) Corsair Dominator DDR3 1600 RAM
Corsair 750W Power Supply
ATI Radeon HD 5770
 


#3
After the disk drivers were unsuccessful,i went to ati.amd.com and tried multiple different versions of Catalyst suite,and i had the same problem. Also,im not sure if its just a driver issue since my device manager doesnt recognize it.
 


reghakr

Essential Member
#4
Forgot did you uninstall the previous drivers first?
 


#5
Yes,i did. Also i went back to the ATI/AMD site and instead of trying to install the Catalyst suite,i tried installing the Display Driver only.I got the same result,but this time when i started up in safe mode *required because Windows goes blank before allowing me to login* i looked in device manager,and it listed my card as ATI Radeon 5700 series,which is correct *YAY!* So i clicked update driver,and it said the ATI Radeon 5700 series driver was the best,and thats what it was using. Tried to reboot *just because* and it did the same thing. Back to safe mode. I clicked roll back driver in device manager.It then read it as Generic VGA Graphics Adapter. Then i clicked scan for hardware changes,it installs the ATI Radeon 5700 series driver,and reads it as that card again,reboot,still doesnt work. So i had to go back to safe mode,roll back the driver,and now itll boot,but im in the same boat still.
 


Sonny

Excellent Member
#6
Go into your Device Manager and disable Generic VGA and then try to install your drivers.
 


reghakr

Essential Member
#7
Is the Catalyst driver download an .exe file?
 


#8
I tried your advice Sonny,still to no avail. Yes,it was an exe. Ive tried a couple and they dont seem to work. Also i tried initially from the disk that came with the PC.Also,when my PC very first boots,it beeps one time.Some googling made me wonder if this is the post message for not recognizing a graphics card?It gave me a bit of hope to see that my computer was able to identify my card correctly. Now if could only boot at the same time:p
 


Sonny

Excellent Member
#9
I am sorry that didn't work. I thought that might be it. I am no expert but I know I had to disable my Standard VGA before I installed NiVida graphics card. Not doing that caused a conflict for me.
 


reghakr

Essential Member
#10
Syncronicity,

Download Universal Extractor and right -click on the .exe file on your desktop.. It should extract The contents of the archive in a folder of the same name, Look for an .inf file, If you find one ,go to Control Panel > Device Manager, right-click on the Catalyst entry and choose update software, the navigate to that folder and select the .inf file.

Let us know the results.
 


#11
Yeah,but the documentation on the website and on several others states that its compatable,and they make drivers for it,as well as,it works for other people. and i recently bought this computer prebuilt,in order to exchange the card,id have to refund the whole PC,then build a whole new one.So im really trying to avoid it being that much trouble,especially since it should work.Ive just finished putting a ticket in to ATI/AMD. So well see how that goes.
 


reghakr

Essential Member
#12
I'd have to say it doesn't''t work for most people. I;ve been at this forum since January 209 and I think I've read enough posts about people having trouble with installing the Catalyst driver and Control Panel.
 


#13
that crossfire mobo has an integrated NVidia graphics card....if you disable it it should automatically read your ATI card...but just as standard VGA. You'll then have to install the ATI drivers. Plus...the Crossfire , or at least the integrated NVidia 590 is designed for an Intel CPU.
 


#14
reghakr-Im not exactly sure what im supposed to do. I downloaded the program you specified,but its just an archive program,to uncompress any kind of file. Where would i find the .inf file? or was the installer not the right thing to download?

Kevin- Are you sure you were looking at the Asus Crossfire III? Because theres no other DMI port on my PC,save the two created by my HD 5770. *Before anyone asks,yes both DMI are from the one card,and yes im sure*
 


#15
sorry champ....I was looking at wrong board.
 


#16
Its alright. If i didnt need help from others,i wouldent be here:p Thanks for taking the time to do some homework:D I currently have a ticket in with AMD,so ill keep everyone posted.And until then,im still open to suggestions:p
 


reghakr

Essential Member
#17
After installing universal Extractor (should haver mentioned this earlier, only choose Extract fies, uncheck all other boxes) it creates a uniextract entry on the right-click context menu, '

right-click on the ,exe file and choose UniExtracr files.

This should unpack all files with a folder of the dame name with all the files in it.

Look for an .inf file, If you find one ,go to Control Panel > Device Manager, right-click on the Catalyst entry and choose update software, the navigate to that folder and select the .inf file.
 


#18
Ok so i right clicked the driver installer for my video card and clicked Uniextract files,and let it run. I couldent find a .inf file in any of the directories.
 


#19
Drew - Thats great,but i JUST paid about $200 for this card,and the card cant be returned as it was part of a prebuild,also installing a new card myself voids my warrenty on the rest of the PC. doesnt seem like a very good move.Ive contacted the builder about the issue,and havent heard back yet. Thanks for your help:)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.