Nearly Impossible To Describe, But I'll Try

Discussion in 'Windows 7 Help and Support' started by Norwood, Dec 2, 2010.

  1. Norwood

    Norwood New Member

    Joined:
    Jun 7, 2010
    Messages:
    22
    Likes Received:
    0
    This morning, while attempting to move some files around my Windows 7 64bit laptop began telling me that I didn't have permission to do so, as I needed permission from the "TrustedInstaller". I googled this issue and resolved it by configuring permissions.

    Feeling a little suspicious I decided to run Malwarebytes. As I attempted to install it, when asked what language I wanted - the program defaults to "Bosanski". Being that I work in IT and have cleaned hundreds of machines I installed it anyway and was able to blindly walk my way through it and run a scan. It came back clean.

    I then went to "Region and Language" in the Control Panel and once I got in there, all the values started scrolling around madly until it settled on "Afrikaans (South Africa).

    I then went to download Speccy, as to give you a screenshot of my system specs and the installer did the same thing. It chose the "Portuguese" language. I then tried to download some other programs and they all did the same thing.

    Another bug that is happening is that when I attempt to move any files, Windows will not allow me to scroll down...it locks onto "My Documents" and then if I scroll down and choose a different directory...it immediately scrolls back up to My Documents.

    I'm at my wits end with this, as googling as brought me nothing. One thread came close to what I was describing but it had no resolution. And most of the things from his log appear identical to mine. I've sent him a PM to see if he came to a resolution but haven't yet received a response.

    Has anyone seen this behavior before? I wonder if it had anything to do with the "TrustedInstaller" problem earlier, yet I applied fixes according to MS kb articles.
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hi, welcome.

    It is completely normal for Windows to do that with TrustedInstaller, even with an admin-type account, when UAC is enabled. Nothing to worry about and it is working properly. As you've found, you can edit permissions on these types of files/folders, but that is highly not recommended.

    You should also set your default regional language and keyboard settings appropriately in the Control Panel.
     
  3. Norwood

    Norwood New Member

    Joined:
    Jun 7, 2010
    Messages:
    22
    Likes Received:
    0
    When I go to those settings in the control panel, all the languages and currencies scroll widely until they settle on Afrikaans.

    edit...When I changed the TrustedInstaller settings I was able to move files.

    Now, these were simply file moves. Moving a jpg to another folder told me I had no permission to do so. Once I changed the settings I was able to move the file.

    I'm doing a system restore now, but the other problems were much more worrisome. Never seen those things before.

    If, by the time I get home this restore isn't finished (taking a while) I'm just going to do a fresh install.
     
    #3 Norwood, Dec 2, 2010
    Last edited: Dec 2, 2010
  4. Norwood

    Norwood New Member

    Joined:
    Jun 7, 2010
    Messages:
    22
    Likes Received:
    0
    Here's the deal.

    I bring this laptop to work, and occasionally add it to my domain. I'm the IT admin here at work so it's not an issue.

    When I brought it back home, it started behaving as normal.

    However, with the changes I made to TrustedInstaller, I'm still wondering if I should do a clean install.

    I most likely will, as I'm home tomorrow with my sick 12 week old...but to add to the information it has something to do with being part of a domain some days and belonging to a simple workgroup other times.
     
  5. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    A clean install would fix these issues, that's what I would do.
    If possible make a system image after the install (after reinstalling software, updating etc.) to eliminate the need
    to clean install again.

    I use Clonezilla Live to make my initial system image and make a new one at least monthly.
    Clonezilla is a live CD or USB flash tool that runs in memory (you boot to it) so it is independent of Win 7.
    It can image an entire drive or a separate partition.

    I save the initial image on an external HDD and always have 2-3 current images saved as well.

    Clonezilla can restore from the external drive.

    It takes me about 15 minutes to create an image and less than 5 minutes to restore.

    My Win 7 system partition is 24 GB and Win 7 uses about 13 GB.

    Since Clonezilla only images the used space and employs a lossless compression scheme the resulting image is only
    around 6 GB in size.

    Since Clonezilla is free it's cheap insurance.

    Clonezilla has a learning curve but once learned it's easy to use.

    I've posted a guide at another forum for those interested.
     
    #5 fjgold, Dec 2, 2010
    Last edited: Dec 2, 2010
  6. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Agreed. Clonezilla is great and I use it as well.
     
  7. Norwood

    Norwood New Member

    Joined:
    Jun 7, 2010
    Messages:
    22
    Likes Received:
    0
    Well, we use GSS 2.5 here at work so I can just make a Ghost image of it.

    This has just piqued my interest at this point. What was going on with permission as being part of a domain that weren't when it's a simple homegroup member...

    How does that effect simple things like moving files from one directory to the next, or simply scrolling....

    It'll give me something for which to look around.
     
  8. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    Yup, a real mystery.
    Ghost image should work.
    Having an image saves a lot of time.

    With me I have 5 Linux distros sharing my HDD with Win 7.
    Having images allows me freedom to experiment and do risky things.

    Clonezilla has saved my butt on many occasion.

    My motto is "If it ain't broke, tweak it until it is".=))
     
  9. Norwood

    Norwood New Member

    Joined:
    Jun 7, 2010
    Messages:
    22
    Likes Received:
    0
    Agreed! It's how I got myself into the business...self taught. I just pressed every button I found, and if I screwed it up, I knew what that button did. If it didn't go haywaire...I found a feature.

    A friend once told me there's nothing you can do to a computer that you can't fix, there' no magic button that'll destroy your computer.

    While this is true...sometimes it's easiest to just reinstall the danged OS...but with enough patience everything can be fixed. That's what I always try to tell people that are afraid of computers...there's nothing you can do to them that can "break" them...other than putting a pick axe to the motherboard.

    Anyway, onto this problem.

    I've narrowed it down to it behaving this way specifically at work. No matter the type of network I identify this as, "Home, Work, Public" it still behaves in this fashion.

    This is the best way I've come up with to describe the scrolling issue.

    You download a file, your browser asks you where you would like this file to be saved...a window opens up showing your directory tree. At the top is ususally "Desktop" then "Libraries" then "Homegroup" etc all the way down to "Computer" and a listing of your drives.

    Say you want to save that folder to your E drive which is lower on that list than is C. You need to scroll down to get to it.

    It isn't allowing me to do that...when I scroll down, it shoots right back to the top.

    Now, that isn't the only time it happens, it happens in other programs (Winamp, moving files from one directory to another, Office products etc).

    I promise you this is no virus as it's a clean install.

    edit...
    Strange gets stranger...

    I use Logitech wirless mice that have USB dongles. I removed the mouse, used only the touchpad and things were fine. Plugged a different mouse in and things worked fine. Plugged the "bad" mouse into a different laptop and things worked fine.

    ...catching breath...bad mouse works fine at home on problem machine.
     
    #9 Norwood, Dec 6, 2010
    Last edited: Dec 6, 2010
  10. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    I believe that's my motto also, at least that's what my wife tells me. lol
     
  11. wt.pm

    wt.pm Senior Member

    Joined:
    May 23, 2009
    Messages:
    184
    Likes Received:
    0
    You probably already know this but, try uninstalling the mouse, (delete it from the hardware manager, clean the registry) I mean completely remove it from the machine, (Revo Uninstaller is great for this), then reinstall updating to the latest driver. I had a problem one time with a keyboard, making my machine do stupid things, not like yours but stupid nonetheless. This fixed it for me. Had a friend that had to buy a new external drive because his would crash his machine everytime, even though it worked on other machines running the same OS. Drivers can do crazy things sometimes. I wish you the best of luck.
     
  12. Norwood

    Norwood New Member

    Joined:
    Jun 7, 2010
    Messages:
    22
    Likes Received:
    0
    My wife is broken and I've been trying to fix her for years. It's hopeless. Yet I can't reformat her try as I might. I wish I could defragment her brain...her analyzation bar looks like a Pollock painting.

    Anyway, it was a mouse issue. Swapped out to the same model yet different physical mouse and all was well.

    I've never seen anything like that...a bad mouse taking a pitchfork to everything from permissions to scrolling. I'm starting to think I've seen it all. :D
     

Share This Page

Loading...