Need help! Toshiba satellite L505D-GS6000 - Cant get High definition Audio Controller

Discussion in 'Windows 7 Help and Support' started by adamf4i, Oct 6, 2012.

  1. adamf4i

    adamf4i New Member

    Joined:
    Oct 6, 2012
    Messages:
    10
    Likes Received:
    0
    Not sure if this is the right section but any help would be greatly appreciated

    Basically I reinstalled windows 7 on my toshiba laptop I got from someone model is satellite l505d-gs6000

    For some reason I have no sound it acts like theres a problem when you clikc on the sound icon which looks muted

    I have downloaded everything I can find on toshiba site to try and get audio driver installed but no luck at all ,

    In device manager it just shows yellow exclamation mark next to high definition audio controller

    Anyone have some kind of generic driver that would work and enable sound to start working , sound devices show no audio device installed

    THanks, in advance
     
  2. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi

    First thing I would try is...

    Right click on the device in Device Manager.
    Click Properties and see if there is a message about the error.
    I.e. Device is Missing etc.

    Next Right Click and select Uninstall.

    When that's done reboot your computer and force Windows to re-identify reinstall and look for drivers again.

    If that doesn't work come back with the error message, maybe that will be a clue as to whats going wrong.

    This seems to be a common issue with this computer, lot of complaints not many answers.

    Mike
     
  3. Adamsappleone

    Adamsappleone U.S.Navy D.A.V.

    Joined:
    Aug 2, 2009
    Messages:
    1,662
    Likes Received:
    122
    Hello adamf4i, [​IMG] to Windows 7 Forums,

    These should be the drivers you need;

    Model Content Page

    Hope this helps

    Don
     
  4. adamf4i

    adamf4i New Member

    Joined:
    Oct 6, 2012
    Messages:
    10
    Likes Received:
    0
    STill not luck with trying all the drivers on the manfacture website , any more suggestions ?
     
  5. adamf4i

    adamf4i New Member

    Joined:
    Oct 6, 2012
    Messages:
    10
    Likes Received:
    0
    Any other suggestions for this as to why its not working , Also when plugging in my iphone or a usb drive into usb ports nothing is coming up no lights on the usb drive or anything ??
     
  6. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Can you read the USB drives in Windows Explorer?

    ---------------------------------------------------------------------------------

    Did you try uninstalling and letting Windows reinstall the Sound Device?

    When you open the Sounds windows what do you see there?

    What is the selected playback option?

    Did it have an error message in Device Manager?
     
  7. adamf4i

    adamf4i New Member

    Joined:
    Oct 6, 2012
    Messages:
    10
    Likes Received:
    0
    Yep , no device when you click on the sound icon in the bottom right taskbar
     

Share This Page

Loading...