Need permissions to copy files: NOTHING WORKS!

#1
Hello,

As the title suggests, I'm having the common problem everybody is facing with file permissions and Windows 7. I have tried all solutions I could find on this forum, but nothing worked. Here is the situations:

- I used to run WinXP Professional. I copied all my files to an EXTERNAL drive.
- Now I have an HP laptop running Win 7. I'm trying to copy my files onto its HDD; I need to empty the external drive in order for me to use it as backup.
- Out of my whole archive of 222GB of everythign (images, MP3's, projects and software) I have 50 odd files that won't copy. They are all EXE's.

I get the usual error: You need permissions from <insert owner's name here> to copy this file. Needless to say, I am the owner; I made sure I am.

I tried everything:
- Take ownership (in various ways), then give permissions. doesn't work.
- run things as administrator
- log in as global administrator
+ take the drive back to my XP laptop: this doesn't seem to work now as Win7 seems to have installed its magical permissions on my files.

there is one peculiar things that I've noticed which might help a little locate the problem: I have folders with read-only attributes. I uncheck that attribute and hit ok, Win7 applies changes. I hit properties again, READ-ONLY IS THERE AGAIN!

Is changing attributes locked along with permissions???

Okay, so what do you think, guys? I'm getting a little frustrated here. :-L
 


#2
Addition:
======

Could that be related to the fact that everytime I shut my computer down, next time I start it up and start my Bluetooth console, drivers reinstall?

I suspect something on an administrative level is preventing changes. It's like deep freeze or something; except with permissions, it doesn't have to restart.

BTW, permissions change, attributes don't. Drivers reinstall upon restart. I hope I didn't make that confusing.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.