Needs elevation (the usual fix doesn't work)

Discussion in 'Windows 7 Help and Support' started by pmennen, Nov 16, 2011.

  1. pmennen

    pmennen Well-Known Member

    Joined:
    Aug 10, 2011
    Messages:
    37
    Likes Received:
    0
    On a Windows 7 ultimate system (svc pack 1), when I try to open any file in the my documents folder I get an error message that says that this operation "needs elevation".

    So I picked one particular file that I couldn't open and I looked at the owner in the security tab. Indeed the owner was not set to me. It was set to "Administrator". Although I'm logged in as an administrator, my login has my name in it, so this was not me. (I don't see any other user accounts however). So anyway I go ahead and change the owner to me. If I cancel and go back in thru properties I see that this worked. (i.e. I am now listed as the owner of this file). However windows still will not allow me to open the file (same error messages). I have the permissions set to "Everyone", and all the permissions are checked. (I do this to allow full file sharing, even with non Windows 7 computers). I've tried playing with various permissions, but everything I see is checked. Why is windows still so insistant that I shouldn't open this file?

    By the way, I tried copying the file to another drive. Windows allows that, but again I can't open it. Then I deleted this copy, which windows did without complaint. I'm dumbfounded. Windows thinks it's perfectly acceptable for me to have rights to delete a file that I have no right to even look at.

    I also tried changing my "User Account Control" to the lowest notch (never notify). However I still get the dreaded "Needs elevation" warning just the same.

    I verified that the files in question are still good by copying them to another computer. From that computer the files open just fine.

    By the way, I have run Malwarebytes and Superantispyware. Both found and fixed a few problems, but still this needs elevation problem remains.

    Thanks in advance for any suggestions you may have.

    ~Paul
     
  2. Krypto

    Krypto Extraordinary Member
    Premium Supporter

    Joined:
    Oct 31, 2009
    Messages:
    1,107
    Likes Received:
    37
    it it just the current files in the documents folder did you try and make a test document to see if you could open it
     
  3. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    If you are seeing "Administrator" as the owner, then at some time previously, a user has enabled the Global Administrator account and secured the ownership under that . It should only show Administrators (with the "s")

    This may not take you where you need, but You can try to reenable the account and see what the situation is then. To do this:
    There are a couple of ways:
    Open a command prompt (Run as Administrator.)
    Type the following command and enter.

    net user administrator /active

    Log out and see if you have a new alternative login, as well as your existing one. If not, do it the long way.

    Shut down the computer for a cold boot. Tap the "F8" key as you are booting.
    Select "Safe Mode with networking" from the boot menu.
    Log into windows 7 with your personal account that holds the administrator access.
    Open a command window (START--->RUN--->CMD.exe). At the command prompt type the following
    net user administrator /active
    Log out and log back in as administrator.

    Another way:

    Go to Start
    Type Control UserPasswords2. (or Open the Start menu, and type lusrmgr.msc )
    Click Advanced.
    Click Advanced again.
    Select Users.
    Select Administrator and untick the the box “Administrator is disabled”
    Now log out and login as Administrator.
    The action leaves you a little more vulnerable to outside attack. Not a big issue if you are confident with your anti virus control etc.
     
  4. pmennen

    pmennen Well-Known Member

    Joined:
    Aug 10, 2011
    Messages:
    37
    Likes Received:
    0
    > If you are seeing "Administrator" as the owner, then at some time previously, a user
    > has enabled the Global Administrator account and secured the ownership under that .

    Actually I had misstyped that. It really said "Administrators". But no matter that ... it looks like this could still be some kind of global administrator account and it was indeed disabled. I re-enabled it using "lusrmgr.msc" and then I selected that account via "switch user". At that point, I did regain access to my files ... even the files that I had already changed the ownership from Administrators to my own login name (also and admin account). This is no good however since all my user settings are gone since they are associated with my login and not this global administrator account. I tried logging back into my own account, and tried the procedure again of switching the owner of a file from "Administrators" to my own account. I was hoping the only reason this didn't work last time was that it didn't allow the change because the "from" account was disabled. No luck however ... as before it still reports that the ownership was transfered, and yet it refuses to open the file.

    So how to proceed? I suppose I could copy all my user settings into the global admin account (although I don't actually know how to do that), and then I could just use that one (and abandon my old account). Admitting that my old user account is permanently broken sounds a bit severe.

    I'm wondering though ... since it is possible to copy these files to another computer and open it from there, it seems that windows has must somehow be stripping off this ownership data so the new computer can access it. If so, isn't it conceivable that Windows has a way of doing a similar copy to a different place on the same computer, somehow turning it into a raw DOS file that any user can access? Then I could just delete the originals, and copy the new files back to where they belong. Probably there is a reason this won't work or you would have suggested it already, but I'm just reaching for a way to get the computer working again.

    Its amazing that microsoft thought that it was necessary for the permissions of a file to have this level of complexity. Equally amazing that they thought that something so complex would actually work.

    Thanks for your reply, and thanks in advance if you or anyone else can offer further suggestions.

    ~Paul
     
  5. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Still thinking of an answer to the problem!!
    But "Its amazing that microsoft thought that it was necessary for the permissions of a file to have this level of complexity"

    UI,an many others, during the Vista beta testing phase, suggested that if we purchased the rights to use the OS, it meant just that - full access. It should be automatic, with heavily supported, a warning and "click" option to move to a user account.
    This fell on deaf ears, I'm afraid. Microsoft felt they were protecting the "average" user from himself(??) sobeit.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I did not see some information that might be relevant.

    What type of file is it?

    What OS is running on the Other computer and are they networked, so you could try to open the file through the network.

    Also, in some cases there may be an Unblock button under the General Properties of the file. I have seen it restrict access to help files, but not much else, but you might check and unblock if it is blocked.
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I am not sure to what extent someone or something (malicious software) may have altered the properties of the problem files but in addition to taking ownership you may also need to examine the NTFS security permissions under the security tab as they pertain to your specific user account, the administrators group and or creator / owner or any other group that your account might also be a member of. Making sure that you and any groups you are a member of have the relevant permissions necessary.
    And as saltgrass points out if you are attempting any of this across the network then "Share Permission" are also a factor and need to be adjusted properly. Keeping in mind that any explicit "Deny" will overrule any other permissions in place.
    Regards
    Randy
     
  8. pmennen

    pmennen Well-Known Member

    Joined:
    Aug 10, 2011
    Messages:
    37
    Likes Received:
    0
    > What type of file is it?

    That innocent looking question from "Saltgrass" turned out to be key. Most of the files in the folders in question where .doc, but I thought the problem was with all the files. It turns out the problem was ONLY with the .doc files and the problem has nothing to do with the files themselves and everything to do with the application that I was using to open them. It turns out that if I start open office by double clicking on soffice.exe, open office will start and I can indeed open all the files in question. So it turns out I had access to these files all along and I just didn't realize it. However when I double click on swriter.exe instead, I get the dreaded needs elevation error.

    This is surprising since I'm pretter sure that soffice.exe must call swriter.exe when you open a .doc file. Now that I know where the problem is I should probably move this to an open office forum, although if any of you have any advice, I will still check back.

    As a final comment on this "needs elevation" error, it seems that this error message shows extreme incompetence on Microsoft's part. Even a programmer right out of high school should know that an error message such as "Permissions not allowed when trying to access file "c:\program files\folder1\foobar.bin" would be far more useful. With such a useless error message as the one that actually appeared it is not too surprising that I assumed the files I was trying to open were the problem, which led me down this long and unproductive path.

    By the way, in my various google searches to find information about this type of problem, I ran into a program called "icacls.exe" which is included as part of windows 7. It turns out that this program can reset permissions of any or all files (recursively if desired) and solve some problems that appear to be resistant to any other attack. In fact when I reset the permissions of my doc files with icacls and the files still refused to open, was when the light finally turned on about the nature of the problem.

    Thanks to all who contributed to this thread.

    ~Paul
     

Share This Page

Loading...