netsh mbn show interfaces results in command not found on Win7 64Bit

Discussion in 'Windows 7 Networking' started by mariovde, Mar 30, 2012.

  1. mariovde

    mariovde New Member

    Mar 1, 2012
    Likes Received:

    I'm trying to run "netsh mbn show interfaces" from a .bat or .jar file on a Windows 7 64bit system but every time I run my file, it results in "The following command was not found mbn show interfaces".

    When I run that same command in a cmd.exe prompt, the result is correct and as expected.
    When we run /? we see "mbn" in available commands. When we output that same result from a .bat or .jar, we don't see that "mbn" command in the available commands for netsh.

    Anybody know what's happening?
    We know there are 2 netsh.exe files, one in sys32 and one in syswow64.

    All help is appreciated.


  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Oct 16, 2009
    Likes Received:
    I am not a script writer, but since it has been 2 days, I will wade in. Maybe it depends on from where or how you are trying to run the command. As you point out, the entire command (netsh mbn show interfaces) runs fine from an Admin (or normal) command Prompt run from the system32 folder.

    It also runs fine if I run it from the netsh shell (mbn show interfaces). I do not have any mobile broadband services running, so I cannot comment on the results. Maybe if you posted some of the script, someone might know.

    Do other netsh commands seem to work?

Share This Page