Network connection vanished after hardware upgrade

Discussion in 'Windows 7 Networking' started by Dobes, Apr 11, 2011.

  1. Dobes

    Dobes New Member

    Joined:
    Apr 11, 2011
    Messages:
    2
    Likes Received:
    0
    I upgraded my desktop's cpu, motherboard & memory the other day, but didn't do a clean install of Windows 7. It caused me some problems, but I have most of the issues resolved.

    However, there is one issue I can't resolve & it is regarding my network/internet connection. I have my Billion modem plugged into a D-Link Wireless Router, whihc is then plugged into 1) My desktop (Windows 7); 2) Work Laptop (XP SP3) & 3) Canon network printer. All was working fine before the upgrade. New mobo is an Asus P8P67 LE, with Realtek on board network adaptor.

    Now, I can't access the internet or the home network through the desktop. The cable is plugged in, but there is no acknowledgement of the PC being connected to anything. The lights around the LAN port on the mobo don't go on when a cable is connected, the light on the router doesn't go on when the cable is connected & Windows 7 says there is no connection.

    I tried plugging the modem directly into the PC, & the internet connection works, so I know the LAN port is working on the new mobo. I've also tried all combinations of cables & ports between the pc, the laptop & the router.

    How can I fix this? As far as I'm aware, the software for the Router is up to date & so is the software for the motherboard.

    Is there a compatability issue between router & ethernet adaptor, or is the router broken?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Dobes;
    Hello and welcome to the forums.
    If as you have said, you've been able to confirm a good ethernet port on the D-Link as well as a good cable then;
    First go here and make sure that you are using this driver (Win7 and WinServer 2008 R2 Driver 7.041 2011/3/21 625k) with your Network adapter.
    Additionally,
    Check and confirm that you are using the latest firmware update for your router from D-Link.
    Temporarily disable IPv6 in the properties of your adapter.
    Type ncpa.cpl into the search or run dialog box and hit enter.
    Select then right click the problem adapter and choose properties and uncheck the box next to Internet Protocol Version 6 (TCI/IPv6)
    Ok your way back out of there and see if it helps.
    If not set the speed and duplex of the adapter manually to 10 half.
    Again type ncpa.cpl into the search or run dialog box and hit enter
    select then right click the problem adapter and choose properties.
    click the "Configure" button near the top of the resultant dialog box.
    Select the advanced tab.
    In the left column look for something called Speed & Duplex, might be called Link Speed / Duplex Mode, etc.
    In the right column click the drop down arrow and select 10Mbps/Half Duplex
    OK your way back out of there and reboot.
    See if that helps. If so you may want to experiment with other settings, 100 half and or 100 full
    Good luck and keep us posted.
     

Share This Page

Loading...