Network Discovery Crashes Router

Discussion in 'Windows 7 Networking' started by laddieri, Jun 30, 2009.

  1. laddieri

    laddieri New Member

    Joined:
    Jun 16, 2009
    Messages:
    4
    Likes Received:
    0
    I have been having a problem with my home network crashing when using WIndows 7. For some reason, whenever I tried to access shared folders or computers on my home network, windows 7 would show "limited connectivity" and I would lose my internet connection. The crazy thing, is that Windows 7 was somehow causing my router to fail because all of my networked computers lost their connections (wired and wireless) until I reset the router and restarted windows 7.

    I recently turned off "network discovery" in my network control panel in WIndows 7, and the problem seems to have stopped. But now I still can't access shared computers, folders, or printers. Does anyone have any idea what is going on?

    Router: Belkin wireless G router with the latest firmware
    Adapter: Realtech integrated into my gigabyte motherboard
    Windows 7 build 7100 64bit (Although I've had the same problem with other early Windows 7 builds)
     
  2. Bruce B

    Bruce B New Member

    Joined:
    Nov 5, 2009
    Messages:
    4
    Likes Received:
    0
    Same problem

    What router are you using?

    I didn't notice it was crashing the router first off and so originally though it was a problem with Windows 7, possibly driver problems.

    I'd originally been using Win7 through a virtual machine and didn't have any problems at all, however when I did a fresh install of Win7 and started using that I immediately had problems.

    I first noticed it with MSN Messenger, I couldn't stay online at all. It would constantly reconnect.

    I thought I resolved it by switching messenger programs to pidgin but finally realized the router was crashing when I noticed I was being disconnected in other things as well. I checked the router logs and sure enough the router was crashing.

    I actually had other routers I could try so I replaced my original linksys BEFSR41 with another linksys, model BEFSX41 both are older models and most recent firmware for them are 2 or 3 years old. Same problem though.

    I have since put in a Dlink 704P, which is also an older model router but, fingers crossed, I've had no problems for 10 or 15 minutes now, which is a Major improvement because with the linksys if I logged in to MSN it would be down in less then a minute.

    You running on a linksys as well?
     
  3. Bruce B

    Bruce B New Member

    Joined:
    Nov 5, 2009
    Messages:
    4
    Likes Received:
    0
    Router

    I had a similar problem and tried all kinds of things.

    Finally realized my router was rebooting.

    It was an old linksys router, latest firmware was 3 years old.

    Put a current model dlink in its place and it seems like I've solved the problem.
    Not sure what 'certified to work with vista' gets me but the current dlink had that sticker.
     

Share This Page

Loading...