Network help please!

I have 2 PCs setup with the same version of Windows 7 Ultimate, both with wired connections to my BT home hub 2 router. 1 PC I have no issues with: I use windows explorer to network, and also access from work and mobile using both VNC and Remote Desktop. The other PC, as far as I can tell set up the same, I have intermittent connection issues. Sometimes explorer can't access the network, sometimes VNC can't access it, and (except from other network PCs) I can't seem to RD on to it. The internet is constantly working, and although I can't access using explorer, I can always see the PC, so I think there is something blocking access. I have turned off my firewall (ESET - windows firewall is disabled), and I have allowed the relevant ports for each way of access... I really can't work out what's wrong, and it's very frustrating... I left that PC on this morning so I could access from work, and nothing! Any help would be really appreciated! :)


On pc with problems, type msinfo32 in the start menu then press enter. File | save on the opened screen. Zip the saved file and attach to a post.

We'll see what's going on.

Thanks for the reply. Please find attached :)


You can type systeminfo in a command prompt then press enter. See the Realtek lan number. Then search for it on the left side of this link:


If you have 8111, use the link itself to download and install from.


Install the latest Realtek HD Audio driver which will update your really old one:


Sorry to sound dim, but I can't see the realtek number under the info in cmd...

Last edited:
Use CPU-Z to find out which motherboard you have. Google for the specs on it or go to manufacturer's site to find out the Realtek lan type.

Then download from Realtek's site because it will be the newest available.

Ok, updated bios, realtek lan driver and the HD audio driver... Still not working :(

ESET is likely still blocking although disabled. (That's common.) Try uninstalling and a reboot.

Sorted! thought that changing the port in RD was the same as in VNC, just forward the port, and connect through it... I didn't realise I had to change it in the registry! Changed correctly now, and connected!! Thx very much for your help :)

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.