Network Icon is Showing a Red "X" Even Though I'm Connected

#1
I've been Googling this problem for at least 2 hours and still haven't found a solution.

I've had this problem for a while now and I didn't really mind since I still have access to the internet. However, today I was trying to access my HomeGroup but it tells me that I'm not connected to the network.

I haven't installed anything. Just one day, I turned on the laptop and there the red x was. I haven't had any problems with Windows 7 aside from Firefox crashing all the time. I think it blue screened on me two or three times too.

network problem.jpg
 


Trouble

Noob Whisperer
#2
tessa:
Hello and welcome to the forums. Nice collage, I can certainly see how you may be confused, I was, Just looking at it. What does the network and sharing center have to say. Is your network there private or public, make sure it's set to private. Run the trouble shooter or try the new network setup wizard. Do you have a third party software product managing your wireless connection? Sometimes, actually quite often, Windows 7 likes to manage it and some problems can occur if you have another piece of software trying to do the job instead. If so you might try uninstalling it. As far as the homegroup issue is concerned you may, perhaps want to leave it and attempt to re-construct the homegroup and see if that helps at all
 


#3
I've experienced the same problem ever since I tried to upgrade the driver on my Netgear WPN111 wireless adapter. I went from v2.1 to v3 of the utility for the adapter and now when my wireless connects it displays the icon that normally shows up when it is disconnected. The driver didn't change just the utility, and I am disabling the utility and using Windows 7 to manage the wireless. I've tried going back to the v2.1 for the adapter and still have the same problem. One thing I've noticed is that when I boot to safe mode the network icon shows connected like it's supposed to. The wireless works perfect just like before and when I click on the wireless icon it says connected, it just shows the red "X" on the icon.

Maybe a common problem here with something being changed in the Windows 7 networking? I've seen a few similar postings elsewhere and it seems to be with different wireless adapters. Just wish I knew what it changed when the utility upgraded. I'm contemplating trying system restore next, back to the point before I installed the new driver.

Other things I've tried include:

- clearing all network locations
- clearing tray notification cache using CCleaner
- uninstalling the adapter itself from device manager including checking delete driver
- removing the wireless network and adding it back manually
- hiding and unhiding the network icon in the tray
 


Last edited:
#4
Decided to do a system restore

Since I didn't have too many changes with the system besides the automatic windows updates, I decided to restore my system. This did fix the problem. I think it may have been caused by the Atheros driver updates because this did start after windows updated.
 


Trouble

Noob Whisperer
#5
Thanks for posting back your resolution. Glad to here you have a fix. Was that driver update critical or optional?
 


#6
The driver updates were optional and I opted not to update them. I'm actually a little tempted to update them to see if that really was the problem.
 


#7
Not trying to re-open a dead thread. However, I've been looking for the solution to this issue, but, all my previous searches came up with only users having this issue with Wireless Connections. This is the first one that I found that was an issue with a wired connection. And, for me at least, uninstalling/reinstalling my Atheros 10/100/1000 LAN driver did the trick. Just wanted to put this up here for posterity's sake. Maybe someone down the road, like myself, will come looking for a solution, and hopefully this thread will lead them down the proper path. I didn't think a System Restore would be necessary, so I just opened Device Manager, uninstalled the device, and did a scan for new PnP devices immeadiately. The device was instantly detected/installed, and all began immeadiately functioning properly. And, of note, I've been having this issue, probably since about June, did a Windows Update and pulled down a new driver. Really hasn't bugged me much, as I don't use this computer too much but to serve files. However, I've been consoled into it for the last 3 hours, and staring at the disconnected icon while accessing the machine via RDP just started aggrevating me.
 


#8
Mine SOLVED!
i tried soooo Many Thing from so many forums.
but these steps Solved that Damn X on my internet connection, Also that yellow star that was appeared before it beside my Wireless connection..follow these simple steps:
1-Uninstall all Network Connection in Device manager.(dont uninstall software)
2-MOST Important point: Right Click on my computer--> Manage-->Local Users and groups-->Groups--> in right panel Double Click Users
3- Remove all NT_AUTHORITY**** (something like that) from there
4-Scan for hardware changes and let the Drivers install again

hope this work for u to,if yes pray for me ;-)
 


#9
Fixed mine by deleteing Incoming Connections in Network and Sharing Centre > Change Adapter Settings.

Windows Vista to Windows 7 Upgrade.
 


#10
I know virtual machine programs can malfunction so if you use Virtual Machine or like programs uninstall the network connection mirror and reinstall it from inside the virtual machine control center.
 


#11
There are a few other things that may cause this. For instance I don't share the driver that the others had, but what I was looking at I found there was a Hotspot Shield driver installed into the network connection itself. This is needed for the service to work, but when you're no longer connected to the actual service it shows as being disconnected. Immediately it removed the "x" after I uninstalled the item.

In case you want to find this for me it was under:
My Computer>Control Panel>Network and Internet>Network Connections>
Right-click the connection you use to get online and select "Properties"
then click the Hotspot shield item and "uninstall"

Sorry to res this dead-ish thread, but I noticed this was the highest up on google searches and didn't see any more recent. Enjoy!
 


#12
Fixed mine by deleteing Incoming Connections in Network and Sharing Centre > Change Adapter Settings.

Windows Vista to Windows 7 Upgrade.
Thanx this was the only thing that worked on mine!!!

You were awesome dude...

God Bless!!!:cool:
 


#13
I found out to get the Network icon to stop showing the X when connected for me. I had to go to Customize dialog for the taskbar notifications, and then click the "Turn system icons on or off" link, and then turn the Network icon off. Restart my computer, and then turn the Network icon back on. The icon is now fixed.

I advise that you DO NOT do the following steps, it almost ruined my computer! (read the rest of this to see why)
Mine SOLVED!
i tried soooo Many Thing from so many forums.
but these steps Solved that Damn X on my internet connection, Also that yellow star that was appeared before it beside my Wireless connection..follow these simple steps:
1-Uninstall all Network Connection in Device manager.(dont uninstall software)
2-MOST Important point: Right Click on my computer--> Manage-->Local Users and groups-->Groups--> in right panel Double Click Users
3- Remove all NT_AUTHORITY**** (something like that) from there
4-Scan for hardware changes and let the Drivers install again

hope this work for u to,if yes pray for me ;-)
Following these steps will result in a blank screen after log in. Task Manager will not open, and all you can view is the login screen. This is because you deleted "NT AUTHORITY\INTERACTIVE" from the "Users" group. The only way to gain access to Windows again, is to enter Safe Mode, and add back "Authenticated Users" and "INTERACTIVE" (or whichever is missing) to the "Users" group.

Here is a blog post explaining exactly what was happening to me after deleting "NT AUTHORITY\INTERACTIVE" from the "Users" group, and finding out I had to go into Safe Mode to correct this. Staring at a blank desktop, due to Interactive missing from Users group - Brad Rutkowski's Blog - Site Home - TechNet Blogs
 


#14
I have same thing,shut off ur computer, take the battery out for one minute, put it back turn ur computer on,
 


#15
This worked for me, I'm glad to be rid of it
THANKS !!!! and prayed for saelkelman

Fixed mine by deleteing Incoming Connections in Network and Sharing Centre > Change Adapter Settings.

Windows Vista to Windows 7 Upgrade.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top