Network keeps changing to Public

Discussion in 'Windows 7 Help and Support' started by caesarvvv, Mar 3, 2011.

  1. caesarvvv

    caesarvvv New Member

    Joined:
    Mar 3, 2011
    Messages:
    2
    Likes Received:
    0
    Hello Experts,

    My current Wifi Setup at home is extremely basic. I have a Wireless modem. This is password protected. I picked up a new Dell XPS laptop (64bit Win7 Premium) a couple of weeks ago and went through the basic setup of connecting to the Internet through the network wizard. Everything was working well until yesterday all of a sudden the connection was coming up as "Limited Access". When I checked the Network Center it showed the connection as Public and "Unidentifiable Network". Double clicking on the park bench icon did not let me change the network type either. I was in the admin account while doing this and thought I should have had the privleges to do it.
    I then deleted the connection profile, power recycled the modem and tried again with the same results.
    The only way I was able to get around it was to create a homegroup and then click on the public network and say allow public sharing after which I got a pop with two options -
    Option 1 - "Make only this network private......"
    Option 2 - "Allow all networks Public Access..."

    I selected Option 1 wherein it converted that connection to a private network within the homegroup. Now I remember when I setup the connection the very first time (I'm guessing as part of the build completion process) it prompted me if I wanted a home, work or public network and I selected Home. But now it has changed for some reason.

    I don't think its the modem because I can connect without any issues from my work laptop (another Dell with XP) and my PS3 and iphones. Basically all my other devices are ok except this laptop.

    One other thing that I've noticed is that because McAfee is bundled with the build, Windows Firewall reconizes that its managing the Internet security side of things and has turned itself off but even if I block applications from accessing the Internet when I come back and check the firewall settings, the app has full access. This may be a McAfee bug but thought I'd mention it anyway.
    Any suggestions as to what could have gone wrong? How can I change back to a normal setup rather than have the Homegroup active?

    Thanks in Advance!!
     

Share This Page

Loading...