Network mapped drive to Windows 7 system dropping connection

Discussion in 'Windows 7 Networking' started by jwright8, Feb 15, 2012.

  1. jwright8

    jwright8 New Member

    Joined:
    Feb 15, 2012
    Messages:
    6
    Likes Received:
    0
    I have two Windows 7 Ultimate computers and around
    10 Windows XP (Home and Professional, SP2 and SP3) computers trying to connect
    to it. It's just a LAN (no internet access).

    I have set all of the
    password-protected sharing off on the Win 7 systems. I have tried opening up ALL
    of the permissions and such (since security is not really an issue).

    The
    problem I'm having is this:

    When I try to map the network drive, it won't
    let me merely connect to it. So, I have to click map network drive on the XP
    computer and hit "login with other credentials" and enter the username/pass for
    the user account on the Win 7 machine (we'll say Bob for user and Smith for
    password for the sake of example). It will mount the share (which is actually
    the C:\ root of the drive) just fine.

    The only problem is the moment you
    restart the Windows XP system, it will lose the connection. My fix for it was to
    create a .bat file that contained the following:



    Code:
    net use S: /delete 
    
    net use S: [URL="file://server1win7/server1win7"]  \\Server1Win7\server1win7[/URL] Smith /USER:\Bob /PERSISTENT:YES 
    
    net use T: /delete 
    
    net use T: [URL="file://server2win7/server2win7"]  \\Server2Win7\server2win7[/URL] Smith /USER:\Bob /PERSISTENT:YES
    

    I put it in the Progam Files\Startup folder to run upon boot. For the most part,
    it seems to work after a fashion. Some of the computers, though, will drop the
    connection to the two Windows 7 systems and need to be rebooted 1-2 times before
    they get it back again. Even clicking the .bat file manually will have the same
    result (you will have to reboot) if it drops the connection while you're using
    it. Plus, sometimes it doesn't map the drive correctly (I assume because the
    batch file is running before the connection has a chance to initialize on the
    LAN).

    Any help would be much appreciated, as I am completely at a loss
    here. Any solution that would allow me to map the network share for both of them
    and it remain persistent would be wonderful.

    PS - I've also tried adding
    an "Everybody" user to the permissions on the Win 7 systems with full access,
    but it only seemed to cause problems with the existing connections.

    It might also be prudent to mention that both the Windows 7 and Windows XP
    systems are all 32 bit. I've also disabled the firewalls on the two Windows 7
    systems. Neither of them have any antivirus or security software installed.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
  3. jwright8

    jwright8 New Member

    Joined:
    Feb 15, 2012
    Messages:
    6
    Likes Received:
    0
    Okay, it seems like that fixed my problem. I will post back on this topic if for some reason it doesn't, but I believe that should be it. Thank you very much for the help; I would have never figured that out!
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Good to hear that you have managed to resolve your problem.
    You're welcome and thank you for posting back and updating your thread with the solution that seems to have worked for you.
    Yes, please keep us posted, I would be very interested in hearing if that is in fact a long term solution for you.
    Regards
    Randy
     
  5. jwright8

    jwright8 New Member

    Joined:
    Feb 15, 2012
    Messages:
    6
    Likes Received:
    0
    Okay, just checking back in while I'm thinking about this. The solution still is working wonderfully on my end, so I'd advise anyone with a similar problem to do the same. About 15-20 computers, all shutting down and booting back up at different times (including the two servers) and the drive letters seem to be preserved fine. Thanks again for your help!
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Thanks so much for the follow-up. Glad to hear that the solution still seems to be working.
    Regards
    Randy
     

Share This Page

Loading...