Network not connected - Internet works fine

Hello everyone,

I'm having an issue that is causing me some headaches and have exhausted everything the internet has to offer in the way of solutions.

My computer is on the internet, which is working fine - except that if I go to the Network and Sharing Center, it says that I am not connected to a network. The major problem this is causing is the fact that I can't use Windows Media Center to stream anything over to my Xbox, because it says that I'm not connected to a network:

Running the troubleshooter does nothing.

So far I've:
  • Uninstalled drivers, and reinstalled from my Motherboard's disc which was working fine inititally
  • Uninstalled Apple's Bonjour application
  • Disabled and re-enabled the network adapter multiple times
  • Ran ROUTE DELETE for the hell of it because I read that somewhere
Nothing has worked. If anyone has any suggestions, that would be greatly appreciated.



Senior Member
What router are you using to connect to your ISP? Just having an Ethernet cable connected to your PC so that the internet is available does not automatically set up a network. To have a Home Network you need some type of router. Once you have a router then you can run the Set up a network connection from the Network and Sharing Center.


I guess I should have said something about the network setup.

I have a cable modem connected to a Linksys WRT54G wireless router. The router is wired to a hub in my room, and the hub is connected to my PC and my Xbox 360. There is another Windows 7 machine on the network that is wired directly to the router.


Senior Member
Have you tried to Setup a new connection or network?


If so what happens?

Attempting to setup a new connection will give me an error:

Error 797:
"A connection to the remote access server was not made because the modem was not found."


Senior Member
Is the router set up with a MAC address filter (I do have this enabled on my PC)? This is another layer of protection on your router.

To find your PC MAC address open a command prompt and type:

ipconfig /all

This will bring up the MAC address of all devices on your PC.

Plug your router IP address into your browser, for my configuration I have to put into my browser address to open my router:


This is what mine looks like (I have blanked my actual MAC Addresses for obvious reasons)

This is where you would change your key phrase, etc as well. I would check all the settings from your wired PC to see if something here is blocking your other PC.

Last edited:
Hi Ted,

I'm not sure if my router has MAC address filtering on it. I know for a fact that if it does, than I haven't set it up and neither has the manufacturer. All I did to it was setup the wireless security for WPA2/PSK with a password, which doesn't come into play here because my computer is wired to the router.

Oddly enough, whatever browser I punch into brings back an error that in Chrome says "No data was returned" or in IE "Cannot display the webpage." I know this is the address because that's what I've used before to configure the router. I've also done a tracert to to make sure the first address was, and it was.

It's very strange.


Noob Whisperer
Hi Ryan:
Could you please provide the results of typing
ipconfig /all
into a command prompt on the problem machine
Additionally the same thing from the other machine on the network, that you say is "wired directly into the router".
I assume you have already tried rebooting the entire network, downing all nodes and appliances and then bring them up one at a time starting with the ISP provided, device, then the Router, then the hub and then the computer.
Typically when you cannot resolve an IP address as you describe above (in attempting to access your router's web interface) it's because the two devices (router and computer) are on two different subnets with no gateway present or having information as to how to route the traffic.

From my machine - with the MAC address removed:

C:\Users\Ryan>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : Ryan-PC
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . :

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek PCI GBE Family Controller
Physical Address. . . . . . . . . : xx-xx-xx-xx-xx-xx
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::3c9f:6327:776d:8828%14(Preferred)
IPv4 Address. . . . . . . . . . . :
Subnet Mask . . . . . . . . . . . :
Lease Obtained. . . . . . . . . . : October-10-11 1:04:31 PM
Lease Expires . . . . . . . . . . : October-11-11 1:04:30 PM
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . :
DHCPv6 IAID . . . . . . . . . . . : 180137669
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-03-C3-00-11-BC-AE-C5-62-DD-A3

DNS Servers . . . . . . . . . . . :
NetBIOS over Tcpip. . . . . . . . : Enabled

After restarting the cable modem, router and hub I can access the router's web interface configuration now, but Win7 is still not identifying a network.


Noob Whisperer
Thanks for the update, at least that's some progress.
into the search or run box and hit enter
From the menu bar select advanced and then advanced settings (if menu bar is not present simply strike the alt key to reveal it)
In the "Connections:" frame select the wired adapter above "Realtek PCI GBE Family Controller" and use the up and down arrows on the right to move it to the top.
OK your way back out of there and reboot your computer.
Keep us posted

Hey Randy,

I did what you asked, except that the connection for my ethernet card was already on top.


Noob Whisperer
Sounds like there may be some hardware device (perhaps bluetoooth) or software product (perhaps VPN) that may be complicating your issue.
Type ncpa.cpl into the search box and hit enter, select then right click on devices that you are not using and choose disable. (Not your Realtek)
Can you perhaps simplify your network, at least for the problem machine, eliminate the hub and plug directly into one of the switch ports on your router?
Open control panel and change the view by: (top right) from category to small icons and select the internet options icon and then the connections tab
If you have any entries in the Dial-up and VPN frame area, select and remove until it's empty.
Click the LAN settings button and remove all checks from all check boxes.
Start the computer in safemode with networking and see if the problem persists
Keep us posted

Hi guys,

Sorry I've been silent the past few days - time to futz with my network during the week is hard to come by.

I've removed the hub and plugged both the PC and the Xbox directly into the router, and done everything you asked in your last post with no result.

There is no VPN or other hardware interfering with the network. Which really only leaves software. I've read that some items which are installed along with iTunes can cause the problem, but not sure what to get rid of.


Noob Whisperer
Hi guys,

Sorry I've been silent the past few days - time to futz with my network during the week is hard to come by.

I've removed the hub and plugged both the PC and the Xbox directly into the router, and done everything you asked in your last post with no result.

There is no VPN or other hardware interfering with the network. Which really only leaves software. I've read that some items which are installed along with iTunes can cause the problem, but not sure what to get rid of.
The software you are referring to is called mDNSresponder.exe and is a product of the Bonjour Service (Part of Itunes) as well as a product of certain other software installations and can also be seen in the services console. So....
into the search box and hit enter
look for
Bonjour Service
a peculiar text string like
##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## (yours may be slightly different)
in either case double click the service and change the startup type from automatic to disabled and click the start button.
Have to say that your problem didn't sound like mDNSresponder.exe, but it's definitely worth a look.

Hello again,

I've removed the Bonjour service completely from my system, but still having trouble. It was worth a shot anyway.

Anything else up your bag of tricks?


Excellent Member
Microsoft Community Contributor
I have been watching the thread, but don't like to interfere with Trouble's suggestions, since he is the expert. I don't have any experience with WANs for the overall network, so maybe just deal with getting you to the router.

Perhaps some things to get back to basics. Anything you have already done after connecting directly to the router is probably not necessary to do again. And I will more than likely suggest some things that have already been suggested.

First keep the computer plugged directly into the router and loose the X-Box. After doing this, in the Network and sharing center, do you show any type of network, like a house and where is the red X? If you could attach a snipping tool picture of the Network and sharing center and use Paint to remove any personal information, it might help.

Anytime in here you might do the ipconf process to see what your addresses are showing. On a home system, the DHCP server and Default Gateway, and DNS server are usually the same. In my experience, the real DNS server is kept on the router, along with other settings for the overall network. I don't really know what is required for Workgroup names, but I keep mine all the same.

So, unless someone has changed the address of the router, and it can be done, you should be showing for your IPv4 stuff, and your address should be a of some variance. As Trouble mentioned, checking the information on your roomate's system would confirm. If you are showing some different type numbers, you can enter the addresses yourself to test. And I did see your earlier attachment with the different DNS server address.

Try to use IE to reach the router. If you can't get to the setup page, try pinging the router in an administrative command prompt. If you can't do that, try pinging and can you ping the address of your roommate?

Anyway, maybe something will reveal some info to help..If the router is not being used as a normal router, I am not sure what the addresses should be.

Hi guys,

Been a while and the thread kinda died, but that's my own fault.

Anyway - good news is, I seem to have fixed the problem by doing the following. in the Registry, I gave full control to Local Service and Network Service accounts on HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList. Doing that gave me the opportunity to discover a network and set it as Home.

So, now I have my home network again - but Media streaming doesn't detect my Xbox, and my Xbox won't connect because it can't see any computers. The fun continues!

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.