Network only partially functional under windows 7 x64

Discussion in 'Windows 7 Help and Support' started by pyric, Dec 30, 2010.

  1. pyric

    pyric New Member

    Joined:
    Dec 30, 2010
    Messages:
    8
    Likes Received:
    0
    Back in August I built a new machine using all "Windows 7 approved" hardware. The NIC worked fine up until a 2 weeks ago when the computer began getting a BSOD upon boot. I noticed when booting that it would only Blue screen when booting to an option that included network support (so even Safe mode with network caused a BSOD). I tried reading the dumps but it gave a different file every time as the casue.

    I uninstalled my antivirus (symantec endpoint 11) as it was updating when the failure occurred and was reporting the definitions were corrupted. after reinstalling SEP the BSOD stopped.

    I attempted to update my antivirus again and half way through the process it failed. I then noticed that I could never fully update my mail either and downloading more than 1 file at a time in either IE or Firefox would casue all downloads to stop after a second or two. I then did a wireshark trace and found an error that each time it fails I get the error "TCP window Full" as well as "Zero Window". I connected the same cable to my laptop (running XP) and tried the same download and it's trace does not get this failure. I also connected my desktop directly to my cable modem, bypassing my router... same problem.

    Task manager shows almost no network utilization when this happens. I took screens shots of task manager's usage with my mail download. These images were taken at 14 minutes apart and NO progress is being made even though I have 16000kbps downloading and 320kbps uploading speed on my broadband. I have also updated to the latest driver on the ASUS web site for the NIC and this still occurs. I even installed a new PCI-E NIC by a different NIC vendor and it too fails. The only thing these failures have in common is windows 7. I have tried all of the following based on other threads I have found:

    Update Router FW
    Update Bios
    Update Nic Driver
    Test with no Antivirus
    Disable ipv6

    Ran the following command in an elevated command prompt in Windows 7:
    netsh interface tcp set global rss=disabled
    netsh interface tcp set global autotuninglevel=disabled
    netsh int ip set global taskoffload=disabled

    Disabled SNP in Windows 7 by setting Registry as following: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters] EnableTCPChimney=dword:00000000
    EnableTCPA=dword:00000000
    EnableRSS=dword:00000000

    Set Receive side scaling to DISABLED.

    Anyone have any ideas? I really do not want to have to return to XP for my network to work. It make no since that this went from working fine to not working so quickly.
     
  2. pyric

    pyric New Member

    Joined:
    Dec 30, 2010
    Messages:
    8
    Likes Received:
    0
    OK, so I got a 2nd hard drive and reinstalled everything and the problem went away. If I switch back to the old one the problme returns... that is extremely strange.
     
  3. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,455
    Likes Received:
    268
    Presumably it is the reinstall rather than the change of disk drive which is solving the problem. A lot has gone on since the problem started so it could be a bit late now but did you ever try a system restore to some date which predated the start of the problem?
     
  4. pyric

    pyric New Member

    Joined:
    Dec 30, 2010
    Messages:
    8
    Likes Received:
    0
    I did a restore when the initial BSOD was occuring and it did not resolve it. It is extremely strange as it is still working on the alternate drive and failing on the original. Oh well... at least it is working now.
     

Share This Page

Loading...