Network printer is added but nothing prints?

Discussion in 'Windows 7 Networking' started by RCheesley, Jan 19, 2009.

  1. RCheesley

    RCheesley New Member

    Joined:
    Jan 18, 2009
    Messages:
    10
    Likes Received:
    0
    Hi all,

    Wondered if you could help me out here, I have a HP1315 printer which is shared on an XP box on our home network. I've added the printer but nothing prints - it spools and disappears. Printer works fine from the XP machines on the network therefore assume it's something related to my Windows 7 installation......ideas?

    Ruth
     
  2. DesertMojo

    DesertMojo New Member

    Joined:
    Feb 2, 2009
    Messages:
    2
    Likes Received:
    0
    I ran into problems getting my HP wireless network printer to print. I could detect it and install it, but it just would not print. I was able to get it to print once I realized I had not yet joined the old work-group to which my printer was networked. (Nothing to do with the new "HomeGroup" feature) Once I did that (Same steps as in Vista) and rebooted, the printer worked fine.
     
  3. rl2k05

    rl2k05 New Member

    Joined:
    Jan 9, 2009
    Messages:
    84
    Likes Received:
    0
    I have my dell 1125 hooked up wireless as well and was having the same problem. Went into the configuration of the printer and found it was checked off line. Once I changed that, its printing like a champ!
     
  4. RCheesley

    RCheesley New Member

    Joined:
    Jan 18, 2009
    Messages:
    10
    Likes Received:
    0
    None of these are applicable

    My PC is on the workgroup and authenticated to the machine fine - it will even send the prints and I see them spool.

    When it spools, it is then removed from the queue as if it's printed, but nothing comes out. Printer works just fine from the XP Pro machine it's installed on, and it works fine printing remotely from an XP box, therefore I know it's not the share or the permissions that are problems. I can also access files etc just fine.

    I tried using net use \\nodename\printername /user:username password however this doesn't seem to have done anything (i.e. I deleted the printer before i did it, after running the command there is no printer in the printers & faxes).

    Any suggestions? Others have the same problem here: Live Search QnA - Windows 7 cannot access shared printer on windows XP
     
  5. jimbo45

    jimbo45 New Member

    Joined:
    Jan 20, 2009
    Messages:
    1,208
    Likes Received:
    41
    Hi guys -- I've posted a few answers on this question on this forum -- the trick is to add these printers as LOCAL devices on to your XP installation.

    I did request the mods to make my post on Printer sharing a sticky but it seems to have fallen on deaf ears, however search the forum and you'll find the answer --I don't want to have to type it all over again.

    It doesn't matter if the remote machine is XP, VISTA 32 bit, VISTA 64 BIT or bothe versions of W7. Same for the local machine.


    Cheers
    jimbo
     
  6. hmt321

    hmt321 New Member

    Joined:
    Apr 30, 2010
    Messages:
    2
    Likes Received:
    0
    can you please expand on the above post


    I have a hp f4280 connected via usb to a pc running xp pro,
    the printer is networked and several lap tops (some runing vista, some xp) can print
    I added a PC running win 7 home 32, and it will print test page, and note pad, but will not print from any other programs (firefox, turbocad, open office, adobe)

    the print job shows up in the que but never prints (it will show up in the print que when accessed from the pc it is connected to)

    this is very annoying please help
     
  7. PhilWilliams

    PhilWilliams New Member

    Joined:
    Sep 14, 2010
    Messages:
    4
    Likes Received:
    0
    Hi
    hmt321
    Did you find out the answer... I have exactly the same problem... I can print from notepad to the networked hp printer from my win 7 64-bit pc, but cannot print from word/excel etc.
    The printer on my win 7 pc is set up as network printer.
    The printer is set up on another win 7 32-bit pc as a local printer. That pc can print as you would expect.

    Thanks in advance
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    PhilWilliams:
    Hello and welcome to the forums.
    Have you tried installing the printer as a local printer? Try this
    Open Devices and Printers
    Select add printer near the top menu bar
    Select add local printer
    Choose Create a new port and local port from drop down arrow Click Next
    In the enter a port name do one of the following
    1. \\MachineNameHostingPrinter\Printer'sShareName or
    2. \\ipaddressOfMachineHostingPrinter\Printer'sShareName
    In the install printer driver dialog box do one of the following
    1. In the left panel select your printer manufacturer and in the right panel select your printer model (to use Win7 native drivers) or
    2. Select the have disk button and direct the install process to the folder where you have download and extracted the Win 7 drivers for your printer.
    You will need to download and extract the full featured driver set from the printer manufacturer for your particular version of Win7 x86 or 64bit drivers
     
  9. PhilWilliams

    PhilWilliams New Member

    Joined:
    Sep 14, 2010
    Messages:
    4
    Likes Received:
    0
    Thank you that worked a treat. I thought I had earlier tried creating a local printer but it hadn't worked.

    Cheers,
    Phil
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Glad to hear that you were able to resolve your issue and thanks for posting back with the update. Hope to continue to see you around the forums.
     
  11. mposhinski

    mposhinski New Member

    Joined:
    Jan 25, 2011
    Messages:
    2
    Likes Received:
    0
    I have the same problem. HP F4280 hooked to Vista machine. Trying to print as a network printer on a computer running Windows 7 64bit
    Tried the setup as a local printer. After imputing \\MachineNameHostingPrinter\Printer'sShareName or
    2. \\ipaddressOfMachineHostingPrinter\Printer'sShareName. Get Access denied or "A device attached to the system is not functioning" Tried it both ways. All other computers will print through this network. What next ?
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello mposhinski, and welcome to the forums.
    First make sure you are using the correct Windows 7 driver for your printer on the Windows 7 machine, go here and make sure you download the full feature driver package HP Deskjet Full Feature Software and Drivers HP Deskjet F4280 All-in-One Printer - HP Customer Care (United States - English)=
    I'm concerned about the access denied error message, so first make sure your workgroup is named the same on all computers and the username and password you are using on the Windows7 machine is also present on the Vista machine hosting the printer.
    I have seen a similar problem ususally reversed when the Win7 machine is the host and the Vista machine is attempting to connect to the hosted printer so assuming that you have the top two issues correct we can try the workaround for the access denied problem.
    On the Vista machine hosting the shared printer
    Go here C:\Windows\System32\spool
    Right click on the PRINTERS folder and choose properties
    Go to the sharing tab and then click the advanced sharing button
    Check the box that says "Share this folder"
    Then click the permissions button
    Make sure "Everyone" is selected in the top frame and
    In the bottom frame check the box for full control under the allow column
    Click OK
    Click OK again
    Now under the Security Tab
    Click the Edit button under the top frame
    In the next dialog box that appears select the add button
    In the next dialog box that appears select advanced button
    In the next dialog box the appears select the find now button
    In the bottom frame choose "NETWORK" and click OK
    then click OK again on the box that you go back to
    And then on the next box you go back to click to select "NETWORK" which you just added in the top frame
    And check the box for full control under the allow column in the bottom frame
    You will probably get a security warning, just click yes
    And then you'll go back to the properties box, just click close.
    You may have to reboot, not sure. Won't hurt
    Now see if you can add the local printer port from the Win7 machine as you tried before.
    Keep us posted and thanks again for joining the forum.
    Randy
     
  13. teamnastyboy

    teamnastyboy New Member

    Joined:
    Nov 6, 2011
    Messages:
    2
    Likes Received:
    0
    hello everyone.My problem is that i have had a network set up for a couple of years now and been able to print share ,well all of sudden my printer wont print from any computer on my network except the one its plugged into. I have re installed printer on all comp but still nothing. The printer is reconized on the network but it wont print? please help i have tried everything i could think of.thank you for your time in this matter.
     

Share This Page

Loading...