Network printer permissions denied

Discussion in 'Windows 7 Networking' started by hobby16, Nov 12, 2009.

  1. hobby16

    hobby16 New Member

    Joined:
    Nov 12, 2009
    Messages:
    4
    Likes Received:
    0
    Hi,
    I have a network printer (HP PSC120 controlled by an old PC with WinXP named "Evo", see image). I can print on it from several PC with Win2K, Vista, XP.
    BUT, with Windows7, I can print but I can't change the network printer's parameters (page orientation, ink mode...) so the only mode I can print in is... portrait !
    I know it's just a question of lack of permissions on my Windows7 PC (other PCs can print & modify parameters) but I can't change them since all boxes are grayed, see image.
    Any hint on how to ungray and check those #à^&@ç boxes please ?
    Your help is much appreciated since I've spent hours trying without sucess. Those permission stuffs (for printers !) are driving me mad.
    [​IMG]
     
    #1 hobby16, Nov 12, 2009
    Last edited: Nov 12, 2009
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Select the printer and choose print Server Properties just below the title bar. Click the Security tab,click Add,, click the Advanced tab, click the Find now button and select your name in the list. Click OK, OK again. now select your name in the list and check all checkboxes.

    If this doesn't work, I think I have another solution.
     
  3. hobby16

    hobby16 New Member

    Joined:
    Nov 12, 2009
    Messages:
    4
    Likes Received:
    0
    Thank you for your prompt reply.
    I do what you tell and I can check the boxes. But it changes permissions for the LOCAL printer server, not the network server, so the problem remains: I still have the grayed boxes and can't change permissions for the network server (access with double click on the network printer and click on the link "Modify name, security parameter").
    What's your other solution, pls?:D
     
  4. Jolyon

    Jolyon New Member

    Joined:
    Aug 12, 2010
    Messages:
    6
    Likes Received:
    0
    The security/permissions hoops described below may get you what you need.

    I have been trying to get a Windows 7 RDP session to access additional printer features (additional tray). Connecting from Windows 7 to Windows 7.
    Each time I reconnect, I have to jump through the same set of hoops.
    Everything to be performed in the remote session.
    1) Open Printers and Devices
    2) Right-click on Printer, select Printer Properties
    3) Change Settings
    4) Security Tab
    5) Advanced
    6) Owner Tab
    7) Select Your Name from list
    8) Apply
    9) OK, OK
    One third done.
    10) Right-click on Printer, select Printer Properties
    11) Security Tab
    12) Select Your Name from list
    13) Tick Allow (x3)
    14) OK
    Two thirds done.
    15) Right-click on Printer, select Printer Properties
    16) Accessories Tab
    17) Add Tray(s), configure to your heart's content.
    Done.

    (Sadly, you have to jump through these hoops again each time you remote into the PC)

    Jolyon
     
  5. pcs3657

    pcs3657 New Member

    Joined:
    May 6, 2010
    Messages:
    210
    Likes Received:
    13
  6. Jolyon

    Jolyon New Member

    Joined:
    Aug 12, 2010
    Messages:
    6
    Likes Received:
    0
    Sadly, the link you point to refers to Vista - in Windows 7, it is not possible to right-click on a printer and choose "Run as Administrator".
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Could you give some more details on how your system is setup?
     
  8. Jolyon

    Jolyon New Member

    Joined:
    Aug 12, 2010
    Messages:
    6
    Likes Received:
    0
    Both PCs are running Windows 7 Professional, 64bit.
    The network is peer-to-peer.
    The computer with the printer attached cannot add the remote computer's user(s) as authorised to use the printer. (Unless there is a way...?)
    So, once the remote computer is connected (bringing the local printer with you), you really have to jump through the hoops listed above to get access to the second tray.

    (Incidentally, the local permissions for Administrators are not inherited by users who are administrators. The user who "created" the printer has permission to change accessories, and sets that permission for Administrators, but other users {who are administrators} don't have that ability. They have to be added individually in order to do so. Was very frustrating trying to work that out!)

    Jolyon
     
    #8 Jolyon, Aug 30, 2010
    Last edited: Aug 30, 2010

Share This Page

Loading...