Network - Printer sharing

Discussion in 'Windows 7 Help and Support' started by HelpPJ, Jan 5, 2011.

  1. HelpPJ

    HelpPJ New Member

    Joined:
    Jan 4, 2011
    Messages:
    4
    Likes Received:
    0
    Help, PLEASE! I work in a small business office and my computer is the main one everyone else is networked to. Had XP but I have a new computer now with Windows 7 and I am having trouble getting the network operating so that people can print to my printer. Everyone can get online, but not able to print like they were able to before the new computer. I have it set on printer sharing. I'm not real computer savvy, so it may be that I'm missing something simple. I've named the workgroup the same name we had before. Any ideas? Thanks!
     
  2. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    Are all the computers Windows 7 or are they mixed? I had a real fit with one of my XP machines. You can only use home group on Windows 7. Make sure you are setup as a work network and all computers are using the same workgroup name. Make sure they are all accessible over the network.
    Joe
     
  3. HelpPJ

    HelpPJ New Member

    Joined:
    Jan 4, 2011
    Messages:
    4
    Likes Received:
    0
    Thanks for the reply, Joe. My computer is the only one with Windows 7. The others are a Mac and Windows XP. I have a workgroup set up and we are all using the same workgroup name. It's the same one we used before I got the new computer. Everyone can get online, just not able to share the printer for some reason. Not sure what else to tell you. Thanks again.
     
  4. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Additionally, explain the issue a little more.
    Are you receiving an access denied or other message when you attempt to attach to the network share or
    Are you getting something else, like unable to connect or not available or something else that may tell us more about your issue.
    If you can't browse to the resource then you may need to take additional steps on the Win7 host machine regarding NetBIOS.
    Type ncpa.cpl into the search box and hit enter
    Right click the network adapter you are using (usually Local Area Connection) and choose properties
    scoll as need and select Internet Protocol Version 4 and click the properties button and on the subsequent dialog box click the advanced button and select the WINS tab.
    Near the bottom select the radio button that says "Enable NetBIOS over TCP/IP" and OK your way back out of there.
    Then type services.msc into the search box and hit enter
    In the services console scroll down and double click TCP/IP NetBIOS Helper service, set the startup type to automatic and click the start button.
    Additionally whether the problem is security (access denied) or Computer Browser Service related. Make sure that the Win7 machine that is hosting the network resource is not running any type of third party firewall (Comodo, ZoneAlarm) or Internet Security Suite (Norton/Symantec, McAfee, etc.) unless you are completely 100% expert in configuring such software to work with your network instead of against it. Otherwise completely uninstall any such product from the control panel and then also run the proprietary vendor specific uninstaller (google it) and replace those products with MSE and the Windows integrated firewall.
    Additionally open the Network and Sharing Center, in the left column select Change advanced sharing settings, select the following,
    Turn on network discovery
    Turn on file and printer sharing
    Enable file sharing for devices that use 40- or 56-bit encryption. (You can revisit this later and crank it up to 128 if things improve)
    Turn on password protected sharing
    Use user accounts and passwords to connect to other computers

    Reboot your network. Just turn off all the computers and bring your computer back on line first.
    Keep us posted.
     

Share This Page

Loading...