network printer

Discussion in 'Windows 7 Hardware' started by Bobcoop103, Jul 18, 2013.

  1. Bobcoop103

    Bobcoop103 New Member

    Joined:
    Jul 21, 2010
    Messages:
    70
    Likes Received:
    0
    I have a home network consisting of a Win7 with a CanonMX922 printer installed and a Win8 computer, at one time I could print fromboth but now I cannot print from the Win8 machine so I ran the ADD A PRINTERfacility where the printer shows up on the dialog but will not allow me to addthe printer, I get the 0X00000002 error any ideas on how to correct this,Thanks, Bob
     
  2. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    I would try to uninstall the printer from the W8 machine, reboot, then try to add it back.
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    This is so strange. I do not have a Canon printer, but I ran an SFC on my Windows 8.1 machine and got an "unable to repair file" result. The file turned out to be from a Canon printer .inf file (prncacla.inf).

    If you run a System File Check on the Windows 8 machine and have a problem, we will help you check your log to see if it is the same as mine.
     
  4. Digerati

    Digerati Fantastic Member
    Microsoft MVP

    Joined:
    Oct 25, 2009
    Messages:
    2,069
    Likes Received:
    159
    I am showing prncacla.inf as being part of W8, as seen here - part of its embedded driver database.
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It is probably not related to the problem, but a strange coincidence. The actual file showing bad is CNBJ2530.DPB. And the file may not be bad, just the database used to check it.

    I have tried to see if I could replicate the situation with another Win 8.1 machine, but have not yet seen it on that one.

    It may be related to some update for Windows 8, there have been some large ones lately.

    But uninstalling and reinstalling is a good idea, as Digerati suggests. Other things come to mind if reinstalling does not work, and those would be anti-virus utilities and Firewalls.

    And I may have the wrong error definition (0x00000002), but it might be a "File not found" type of message.
     

Share This Page

Loading...