Network Sharing a Password Protected Folder on Home Network

Discussion in 'Windows 7 Help and Support' started by btvarner, Oct 17, 2012.

  1. btvarner

    btvarner New Member

    Oct 17, 2012
    Likes Received:
    This question is long and has been written about much in many strings in this and other forums. None have worked for me to date.:cool: I think that the issue may be that the provider of answers to these other similar questions seem to assume that the overall setup of the machine in question is in a virgin install state for all the settings. I have been trying to resolve this for several days and have made many changes in many places in an attempt to solve. I am hoping that by providing a very detailed question, someone can provide an overall answer and not just reference an article that gives general overviews. I am afraid that I may have other settings that now require adjusting because they might be different than initial settings. Thank you in advance.

    GOAL: To share a password protected folder (and its sub folders) on Windows 7 Ultimate 64 bit PC with other PC’s on a home network. Those other PC’s consist of both Windows 7 & Vista PC’s. User on those other machines would be able to see the shared folder but not able to connect unless they provide a valid user name and password. My wife’s PC would need to be able to have a persistent connection to this shared folder. The other PC’s would only connect as needed for short periods of time. Bottom line is that no one can have access to the contents of this share without entering a specific user name and password. I have no homegroup set up because of the mix of Windows 7 & Vista PC’s. Each user of each PC has a different login.

    Here is what I have done so far:
    Computer Management- Shared Folders\Shares\Users\User Properties. Removed and then re-added Users. I did this because I found that anyone on my home network can see and access this PC’s Users folders and all sub folders. I put back users because when removed I could not “share” any sub folders under Users, which is where the desired folder is located….
    Target Folder needing to be Shared from Explorer- C:\Users\”My Profile”\My Documents\”Folder to be shared”. Share with specific users. Added a user account created on the machine specifically to be used to log onto this share from other network PC’s.
    Target Folder needing to be Shared from Explorer- Right clicked this folder \ properties \ Advanced Sharing \ Shared this folder. Have since changed back.
    Network and Sharing Center- Change advanced sharing settings. The following are chosen: Turn on network discovery. Turn on file and print sharing. Turn off public folder sharing. Media streaming is off. Use 128-bit encryption. Turn on password protected sharing. Use user accounts and passwords to connect to other computers.

    I please need all these areas addressed to ensure I have not changed something in any of them that is causing failure. At this moment others on the network can see and freely access this PC’s “Users” folder and sub folder. The desired shared folder cannot be scene in network from any of the other home network PC’s.


Share This Page