New computer won't always connect with router

Discussion in 'Windows 7 Networking' started by kennyg, Aug 11, 2010.

  1. kennyg

    kennyg New Member

    Joined:
    Aug 11, 2010
    Messages:
    8
    Likes Received:
    0
    -new computer windows 7

    -connects with router if in the same room and allows me to walk all over the property and remain connected, streaming etc.

    -can't connect from farther away in the house except for really close to the router. It's like windows gives up immediately unless I'm in the same room. Again, once it's connected, it works everywhere. Also, other laptops (win xp) and ipods work no problems from anywhere.

    Router-Linksys WRT110
    computer using Windows 7 and broadcom 802.11n network adapter

    ideas?
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hi.

    Try changing the wireless channel that the router uses.

    Update the wireless network driver to latest for the pc with problems.
     
    kennyg and (deleted member) like this.
  3. kennyg

    kennyg New Member

    Joined:
    Aug 11, 2010
    Messages:
    8
    Likes Received:
    0
    Tried those things but no change. Any other possibilities.
     
  4. Nibiru2012

    Nibiru2012 New Member

    Joined:
    Dec 16, 2009
    Messages:
    466
    Likes Received:
    18
    Did you check to see if your wireless router WRT110 has the latest firmware update installed?

    This is the latest firmware for the WRT110 ver.1.0 wireless router.


    Firmware


    • 11/03/2009
      Ver.1.0.07
      Download 2.81 MB
      (Firmware)
      Release Notes
    Upgrade Instructions


    • 03/17/2010
      Download 0,98 MB
      (Upgrade Instructions)
     
  5. kennyg

    kennyg New Member

    Joined:
    Aug 11, 2010
    Messages:
    8
    Likes Received:
    0
    Yeah, my firmware is updated but I redid it anyway. Still nothing. Thanks for helping. What next?
     
  6. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Try lowering the beacon interval in the wireless settings of the router.
     
  7. kennyg

    kennyg New Member

    Joined:
    Aug 11, 2010
    Messages:
    8
    Likes Received:
    0
    Thanks Torrent and Nibiru. I exchanged the computer on a tip that it may be a faulty network adapter. The new one works fine.
     

Share This Page

Loading...