New SSD Drive turned my Raid0 drives write protected

#1
So, got a new OCZ Vertex 2 120 GB over the weekend. Installed it, everything went fine. Blew away my old install (backed things up of course), loaded raid drivers during install. Formatted both, installed on SSD with my D drive as Games/Music/Etc.

Now everything seemed fine on first boot. Installed everything again, most of everything going my Raid0 drive(s). Worked great.

Boot it up Sunday, my Raid 0 drives are write protected. Odd, so I use diskpart and clear the read only. Works great again. Boot it up Sunday evening. Same thing. Diskpart it again. Cycle repeated again today.

Using the JMicron controller on my EVga X58 Mobo. Have 2 300 GB VRaptors in Raid 0 that work great after using the diskpart command.

Is there some setting I am missing somewhere? Why are they reverting to read only after a reboot? My external 1.5 TB USB 2.0 drive is fine, been able to read/write perfectly throughout.

I'm at work now, so I can't get real specific specs, but if there is any further info needed, let me know and I'll try my best to provide details.
 


#3
Thank you for the response.

Unfortunately, these are all temporary fixes. The chkdsk is definitely the quickest method, instead of going down the diskpart route. However the problem still persists on a reboot.

Maybe what I'll try tonight is moving everything off the drive, running chkdsk, then format. Then move everything back.

After looking around the web, this seems to be a somewhat common problem. There was a regedit fix posted for Vista x64, but it seems Win 7 does not have the same registry values.

Perhaps someone knows the Win7 regedit fix? The one I found for Vista was:

"Change this key if set to 1 back to 0 KEY= HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect"

I get as far as 'Control' as there is no 'StorageDevicePolicies' in the Win7 registry.

Running Win7 x64 Ult if that helps. Thanks!
 


zvit

Honorable Member
#4
You can create it. Backup your registry first!

Put this in a .bat file and execute it: (for some reason when I post this, it puts a space in the word "StorageDevicePolicies". There should be no space.)
cd\
reg add "HKLM\System\CurrentControlSet\Control\StorageDevicePolicies" /t Reg_dword /v WriteProtect /f /d 0

Do the same with the following two locations (creating any non-existent keys/values along the way):

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control
 


Last edited:

Joe S

Excellent Member
#5
This may sound dumb and unrelated but a simple thing to try. I bought a WD 2T USB HD and hated the automatic backup software and uninstalled it. Then I had drive write protected when I tried to access it. After wasting time and not finding a fix I simply deleted the driver and rebooted and everything was fine.
Joe
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top