NFS, Mapped Drives, MKLINK, UAC...

Discussion in 'Windows 7 Help and Support' started by xhenxhe, Aug 31, 2009.

  1. xhenxhe

    xhenxhe New Member

    Joined:
    Aug 31, 2009
    Messages:
    2
    Likes Received:
    0
    I'm trying to set up a development environment at work. I'm the only one using Windows. Others have the environment set up on Linux and Mac. I'm hoping this is possible but I'm stuck on one particular issue that is driving me crazy!

    I need to connect to a shared network drive via NFS. I installed Windows 7 Ultimate because it has NFS support. I was able to map a network drive to the NFS server.

    If I try to use the mklink command to create a symlink, I get this error:
    You do not have sufficient privilege to perform this operation.

    So I run the cmd promt as Administrator. I can create symlinks using the mklink command, but I can't access the I: drive where I mapped the NFS share. I can access my J: drive which I have mapped to Jungle Disk.

    I have also tried modifying Local Security Policy (sempol.msc ) to allow myself access to create symbolic links. It doesn't seem to affect it at all - even if I give "Everyone" permission to create symbolic links. And yes, I rebooted... several times.

    It seems there are two bugs that are causing the roadblock: 1) setting permissions to use the mklink command; 2) Accessing an NFS share with elevated privileges.

    I'm at a loss! Any suggestions?
     

Share This Page

Loading...