No access to a configurationfilei while startin a program (win10)


Senior Member
Nov 4, 2019
A friendly hello to anybody,

I have got a program that lööks into some configuration files when it starts. The program and the configuration files are located on a network server. If I use the explorer, I can open the files.
This program is used cince a long time. It worked well. After an update i found this bug. At the begining the programm could not access differentt files. I tried to alow the access and the bug changed.

What can I do to alow the access at start time?


Hello Peter,

To resolve the issue of your program not being able to access the configuration files on the network server at startup, you can try the following steps:

1. Check the file permissions: Ensure that the program and the user account running it have sufficient read/write permissions on the network server where the configuration files are located. You can right-click on the configuration file, select "Properties", and go to the "Security" tab to review and modify the permissions if needed.

2. Set up a network drive mapping: Instead of accessing the configuration files via the network path (e.g., \\server\share\config), try mapping the network folder to a drive letter. To do this, open "File Explorer" and click on "Map network drive" in the "Computer" tab. Then, select the drive letter and provide the network path to the folder containing the configuration files. This can help ensure consistent access to the files, even on restart.

3. Create a script to copy the files locally: If mapping a network drive doesn't resolve the issue, you can create a simple script to copy the configuration files from the network server to a local directory before the program starts. This way, the program can access the files locally and avoid any potential network access issues. You can place this script in the startup folder so that it runs automatically on system startup.

4. Review any firewall or antivirus settings: Sometimes, firewalls or antivirus software can block network access to specific programs or files. Check the settings of your firewall and antivirus software, and ensure that the program and the network server are allowed to communicate without any restrictions.

By going through these steps, you should be able to troubleshoot and allow access to the configuration files at program startup. If the issue persists, it may be helpful to provide more information about the program, the operating system, and any error messages you encounter.

Hello ChatGPT,​

thank you for your answer. The server is based on Linux with samba. It is not configured with activ directory capabilities. The quarantine of the antivirus is checked. For access a drivr letter is used. I entered the program name in the öist of the firewall. bot the bug is stil there.

A friendly hello to anybody,

I have got new informations. When I start that program normaly it can not find one configuration file, but if I start it as administrator it can't find two other files. How can I fix it?

Top Bottom