No Audio via HDMI External Source

Discussion in 'Windows 7 Help and Support' started by myvinyl333, Dec 23, 2009.

  1. myvinyl333

    myvinyl333 New Member

    Dec 23, 2009
    Likes Received:
    I recently upgraded my Sony VGN-FZ 2900 fro VISTA 32 Bit to Windows 7 Home Premium 32 Bit. After the upgrade I no longer get Audio from my HDMI output to my external home theater system. I get Video and the Audio is present on the Sony VAIO. All was working well prior to the OS change.

    I have looked for driver updates for reltek, or SONY VGN FZ 2900 and none have worked.

    I would greatly appreciate ANY information or guidance
  2. ickymay

    ickymay New Member

    Jan 12, 2009
    Likes Received:
    If you go into your sounds settings from the control panel is the device for your graphics card HDMI output listed there and enabled ?
  3. toddynet

    toddynet New Member

    Feb 14, 2010
    Likes Received:
    A resolution?

    I have been battling for the last 3 weeks now to try and resolve this... HDMI audio output to HD TV worked fine under Vista... upgrade to Windows 7 and it stopped working.
    Nvidia GEFORCE 7650 GS graphics card, plus Realtek HD Audio.

    Tried everything... removing, reinstalling drivers left, right and centre... finally I simply tried rolling back the drviers on the Nvidia card to those from when Vista was running fine... and hey presto, it worked a treat. Now playing fine to my Samsung HD TV via the Realtek HDMI auio on the Playback devices.

    Hopefully this will not compromise anything else... audio still working on my PC speakers...

    I am not sure if this a Windows 7 issue or an Nvidia issue.. I have tried the latest beta drivers from Nviddia and that did not help...

Share This Page