No Bluetooth on Dell Latitude e5500 Windows 7

Discussion in 'Windows 7 Hardware' started by Scarabae, Mar 17, 2010.

  1. Scarabae

    Scarabae New Member

    Joined:
    Jan 12, 2009
    Messages:
    36
    Likes Received:
    0
    I have a Dell Latitude e5500 with a fresh install of Windows 7.
    (It was a vista laptop.)
    Everythings works except Bluetooth.
    I believe its the Dell 370 driver.
    Tried everything, but it simply doesn't show up.
    Bluetooth is enabled in the bios, but tried several drivers.
    In the device manager it isn't shown, & also there are no hidden apps.
    The bluetooth radio isn't enabled I believe.
    I googled & tried a lot, but can't solve it.
    I need help...

    thx. in advance:cool:
     
  2. sogoodtobe

    sogoodtobe New Member

    Joined:
    Mar 11, 2010
    Messages:
    70
    Likes Received:
    2
    On Dell website, you can get the all the required drivers for your PC. Make sure you install the Bluetooth driver and the software suite (DW370 Bluetooth 2.1 for Win7 6.2.0.9600).

    Another good option is to install all Wireless (not BT) drivers as well; on some Dell, both are bundled, only the software gui differs.

    If you still can't see the device under Device Manager, then you might have more serious pbm.

    Cheers.
     
  3. Scarabae

    Scarabae New Member

    Joined:
    Jan 12, 2009
    Messages:
    36
    Likes Received:
    0
    I downloaded latest driver, installation runs good till the notification to enable Bluetooth radio...

    Which I can't seem to find or Enable?

    So what could be the problem?

    It's a very new Laptop.
     
  4. Scarabae

    Scarabae New Member

    Joined:
    Jan 12, 2009
    Messages:
    36
    Likes Received:
    0
    Solved the problem.
    I had one without WPAN module, bought it/installed it.
    So now it's complete, got Bluetooth.
    Case Closed....
     

Share This Page

Loading...