No Device! Will not boot from CD ROM

Discussion in 'Windows 7 Installation' started by CompBJB, May 29, 2011.

  1. CompBJB

    CompBJB New Member

    May 29, 2011
    Likes Received:
    I just bought an ASUS M4A88TD-V EVO motherboard with Lite On SATA 6.0Gb/s DVD-RW and Blu-Ray drives. Everything seems to be connected to the right ports, and when I turned on the computer for the first time and went into the BIOS, it detected my clean/bare Hitatchi SATA 6.0Gb/s HDD, and the two disk drives. I opened the DVD drive (not the Blu-Ray) and loaded the Windows 7 64-bit upgrade/install DVD. I've tried every way I can think of to tell the BIOS to boot from the DVD-RW drive, but when I restart, I get a message, "No Device!" "Reboot and Select proper Boot device or Insert Boot Media in selected Boot device and press a key"

    No matter what I try I cannot get it to boot from the DVD or recognize that the Windows 7 DVD is in the drive and to boot from it.

    Help please!

  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Oct 16, 2009
    Likes Received:
    Did you build this computer? It looks like all the SATA ports are SATA IIIs. The only thing I might think of is to remove one of the DVDs and see what happens.

    If you have the correct DVD set first in the boot priority, it should give you the "Boot from DVD" message, as long as the media is good..

    Does you system have a boot device key to use during boot, like F10?

    It does not look like your system has the uEFI boot interface, but just confirm....

    Those SATA connectors can be a pain, they are fragile and hard to tell if they are fully inserted sometimes.

    Have you tried putting the media in the other drive?

Share This Page