No "Do you want to overwrite it" warning with Save As

Discussion in 'Windows 7 Help and Support' started by martinrad, Mar 26, 2012.

  1. martinrad

    martinrad New Member

    Joined:
    Mar 25, 2012
    Messages:
    6
    Likes Received:
    0
    I have been scanning, editing and saving photographs for several weeks. Initially if I inadvertently selected an existing file name I received the Windows 7 version of the old Windows warning "File xxxxx already exists, Do you want to overwrite it?". Suddenly today I found I was not getting that warning with Corel Photo-Paint and that files were being overwritten. I checked this phenomena with Word 2007 by creating a temp.docx file then creating a new page and using the Save As command with the same file name. It overwrote the original without giving me any warning. I also tried with a temp.txt file in Word and strangely that happily overwrote the original without any warning YET when I tried in Wordpad, the Windows 7 version of the warning appeared.

    A computer guru friend of mine found he had the same glitch so he made a change to his registry that solved the problem and sent me the following message

    1. Open Regedit
    2. In the Edit menu select Find
    3. Type SaveAs in the find window and click on FindNext
    4. SaveAs will be found under the Control Centre Heading
    5. Double click on SaveAs to open parameters window.
    6. Change value from 0 to 1
    7. Close Edit and reboot.
    This will enable the overwrite prompt.
    When I looked for his suggested "SaveAs" I could not find one in my registry. Amazingly when he went to find out the exact location of his change he found that it had been made in a Brother Printer section - but it solved his overwrite prompt problem in Word 2007!!!

    I have some CORELDRAW registry entries that contain "SaveAs" in their text lines and have 12 as the value. I have checked on my XP system and 12 is also the value used so I do not think a change there will do anything - particularly because the glitch is also happening in Word. I have also checked options available within COREL PHOTO-PAINT.

    I would greatly appreciate a solution because I have a large number of photos to scan and store and having to scroll through a long list every time to ensure I do not overwrite a file will be a pain in the but.

    When copying files from one folder to another the 'Copy and Replace' and "Don't Copy' options appear as they should.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I don't seem to have any registry entries such as you suggest.

    I do not have any Corel products, so I cannot address that.

    Word 2010 had to know the file being overwritten has different attributes from the one being written. So if the new file was just changed, it will happily overwrite the original. If you start a new file then it should give you a warning.

    If the two files have different extensions, like .doc or .docx, it seem to overwrite the original, but of course it is not.

    I do not see an option in Word to turn on or off the warning message.

    As a workaround, until you find a solution, you might save the files in another folder and move them later. That way, you would only have to remember one session.
     
    #2 Saltgrass, Mar 26, 2012
    Last edited: Mar 26, 2012
  3. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
    Not much help but I tried word 2007 and Photoshop elements and they both prompted me with warning. So it's probably not WIN7 Issue.
     
  4. martinrad

    martinrad New Member

    Joined:
    Mar 25, 2012
    Messages:
    6
    Likes Received:
    0
    Strangely, this morning (I live in Western Australia so we are half a day ahead of you guys!!) I started my computer, cleaned my registry with Uniblue's RegistryBooster, restarted and then created a page on Word, saved it as temp 1.docx, closed it, created a new page, tried to Save As using the same name and I got the desired warning. This is exactly the procedure my computer guru friend and I followed on separate computers yesterday when we did not get the desired warning. Possibly it all depends on "how you hold your mouth" as the saying goes!! However Corel is still not giving me a warning so I will fully uninstall it and try again. If that does not work I will use Saltgras's suggestion and save to an interim folder for each scanning session.
     
  5. martinrad

    martinrad New Member

    Joined:
    Mar 25, 2012
    Messages:
    6
    Likes Received:
    0
    Sorry for leading you up the garden path with this glitch. It was solved as soon as I figured that whilst CorelDraw 12 appeared to be working in 32 bit mode under Windows 7 (except for this glitch), it might run better in Windows XP Mode in the Windows Virtual PC that is available in some Windows 7 versions - I have Professional which is compatible. For those that may be having problems with older software that they do not want to upgrade to 64 bit this is what you have to do.
    After installing the Virtual PC and Windows XP mode you may get “The Windows Installer does not permit installation from a Remote Desktop Connection.." when you try to install a 32 bit program. If so:

    1 Start Virtual Windows XP mode (if not alraedy started).
    2 Load the content of the program installation CD/DVD into a folder on C: drive of the XP Mode (Not in Win7 - I used the 'XPMUser's Documents' folder to be sure)
    3 If XP window is maximised reduce the window so that you see "Tools"
    4 Click on Tools - Disable Integration Features
    5 You then have to give the administrator password (if you set one for XP)
    6 This will make the win7 drives invisible
    7 Install your program from the XP drive/folder you stored the installation files on.
    8 Delete the installation files - if you want to.
    9 Click on Tools - Enable Integration so you can use the Win7 folders to open and store files.
     

Share This Page

Loading...