No internet after sleep mode

Discussion in 'Windows 7 Networking' started by ge974me, Jun 8, 2009.

  1. ge974me

    ge974me New Member

    Joined:
    Jun 8, 2009
    Messages:
    4
    Likes Received:
    0
    Hello,

    I have installed Windows 7 RC in 2 differents computers, a notebook and a laptop, and I have no internet when they wake-up after the sleep mode with the WIFI connection. I use DHCP.
     
  2. BurrWalnut

    BurrWalnut Extraordinary Member

    Joined:
    Nov 14, 2008
    Messages:
    97
    Likes Received:
    13
    I've posted this before, it may help you:

    Go to Control Panel > All Control Panel Items > Network & Sharing Center > Change adapter settings (in the left pane), right-click on the connection you‘re using > Properties > Networking Tab. Now remove the tick from the IPv6 box. If it makes no difference or causes problems it is completely reversible by ticking the box.

    Also, click the Windows Orb (Start), type devmgmt.msc and press Enter. Expand Network Adapters > double-click the wireless adapter > Power Management Tab and make sure the check box is cleared against ‘Allow the computer to turn off this device……’.
     
    #2 BurrWalnut, Jun 8, 2009
    Last edited: Jun 8, 2009
  3. ge974me

    ge974me New Member

    Joined:
    Jun 8, 2009
    Messages:
    4
    Likes Received:
    0
    Thanks, but it doesn't work. I didn't have this prob. with Vista and XP. Do you have an other way to solve this problem ?
     
  4. halcion1

    halcion1 New Member

    Joined:
    May 13, 2009
    Messages:
    48
    Likes Received:
    6
    Try this...

    Check to see if you have this little devil in your services list:

    "##Id_String2.6844F930_1628_4223_B5CC_5BB94B87 9762 ##"

    If you do, stop it and disable it. It is actually the Bonjour DNS Responder Service, and I believe it is the cause of the "Unidentified Network."

    The Unidentified Network disappeared after stopping this service and a quick disable/enable of the NIC, restoring Internet access.

    I Actually just rebooted, edited this post, and then re-enabled the offensive service to see what would happen...Immediately after enabling the NIC and this bastard service, the "Unidentified Network" returned...stopped it, disabled it, disable/enable NIC...Internet back up and running and no "Unidentified Network." (woot - woot!)

    Hope that helps! I haven't had issues since...
    :razz:

    FYI - I experienced this in both build 7100 and 7127...I am running 7127 now x64 - and discovered this fix just last night...so far so good just rebooted and then edited this post...I believe this fix will solve 7100 build issues too; however... I have not tested 7100 again yet.

    ...I also re-enabled Win 7's Discovery Mapping services, but always leave IPv6 disabled just because I am not using it.

    ...another two reboots, and a hard disk addition, and no problems with the Internet! - If you tried another fix such as changing the address of your network adapter, under "Advanced" - this is not necessary...I set mine back to "Not Configured." Everything is working fine as long as the Bonjour service is not running...

    My system:
    ASUS P5E
    Quad Core Q6600
    4GB Corsair Dominator DDR2
    NIC: Marvell Yukon 8E8056; driver v10.69.2.3 (4/21/2009)
    ***fyi - i did update the default Windows driver with this, Vista x64 driver

    For the record, there is some blame pointing towards the following software, of which I do have installed and running properly:
    Office 2007 SP2
    Adobe CS3 (updated current)
     
  5. aharown07

    aharown07 New Member

    Joined:
    Aug 13, 2009
    Messages:
    6
    Likes Received:
    0
    I'm having this problem also on my Toshiba Satellite Pro s300-s2405... intel wifi adaptor.
    Tried all the ideas posted here. So far no go. Worked fin in Vista... but I was not able to get my hands on the same driver. Toshiba has updated Win7 "beta" drivers so I'm using that.
    But it doesn't get through to internet after sleep.... which means alot of rebooting until I get it figured out or a new driver becomes available.

    So any other ideas?
     
  6. textureDnB

    textureDnB New Member

    Joined:
    Jun 29, 2009
    Messages:
    652
    Likes Received:
    6
    Have you also checked in power management to make certain that IT isn't turning off the adapter?Also will right clicking the icon and selecting troubleshoot problems re connect you without a reboot?Not exactly the answer your looking for but if it works it will save you some rebooting.
     
  7. aharown07

    aharown07 New Member

    Joined:
    Aug 13, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks, but, yes, tried both of those. Also, logging off and back on makes no diff. Have to reboot.
     
  8. aharown07

    aharown07 New Member

    Joined:
    Aug 13, 2009
    Messages:
    6
    Likes Received:
    0
    Got it!
    Wish I could remember where I read this, but somewhere in my googling, someone said uninstall the driver (don't delete files) then reboot and let Win7 install it again.
    Did that, works like a charm now.
    Seems like it's always something so obvious I overlook it in search of a more complex solution.
     
  9. tat2dmcse

    tat2dmcse New Member

    Joined:
    Dec 3, 2009
    Messages:
    2
    Likes Received:
    0
    Found this on another forum, and it worked great for me.

    Change your network adapter advanced settings to these values:

    Sleep on disconnect: enabled
    flow control: disabled
    interrupt moderation: disabled
    ip checksum offload: disabled
    jumbo packet: 9014 bytes (this might have no effect for you)
    ALL large send offloads: disabled
    BOTH low power: enabled
    network address: not present
    priority & vlan: priority enabled
    receive side scaling: disabled
    speed/duplex settings: auto
    ALL TCP & UDP offloads: disabled
    vlan id: 1
    ALL wake ons: enabled

    Hope it helps
     

Share This Page

Loading...