No internet connectivity

#1
I installed Windows 7 Ultimate 64 bit editon a few days ago. Today when I turned on my computer I had internet then I played the online game APB and noticed i had some lag so I logged off apb restarted my computer and then it said my internet was out. I went to connect back to the network and it couldnt find it. I ran all windows updates a day before this. Im connected into a new cisco linksys e2000 via a ethernet cable. The rest of the family connected wireless into it. Everything works that connects wirelessly expect for me. I even plugged in a usb adapter and it didnt work but works for everyone else. Ive spent all day trying to find a solution and nothing has worked. I know its something with windows 7 ive installed 4 updates that they told me to install and nothing happened. I have no dns and only an ip default and subnet. When i do ipconfig /all everything is zero and it says media disconnected on it all. All the lights on the router and modem are on and it says im connected. All pings ended up saying cannot reach. Anyone have any suggestions?
 


#2
You can try resetting the network stack. Open an elevated command prompt. Copy and paste each line, then hit enter after each:

Code:
netsh winsock reset
Code:
netsh int ip reset
Reboot and test.

Also, please let us know if you have mdnsresponder.exe in the task manager or not. If you still have problems after these commands, please post a screenshot of ipconfig /all
You can use snippingtool by typing it in the start menu and hitting enter. Then use the paperclip above where you type in advanced mode reply, to attach.
 


#3
Capture.JPG It seems like theres something on windows 7 thats blocking the connection even when I have no firewalls.
 


#4
3 things I can suggest

1) See if there is a firmware update for the router and install.
2) Visit your motherboard manufacturer's website for the latest NVIDIA lan driver to install. It may be part of the chipset package, or stand alone.
3) From one of the wireless pcs, go to the router's configuration page and make sure that there isn't any mac address filters set against it. Or alternatively, check that it is specifically allowed if that's how the router is configured to operate.

If all else fails, setup a static ip address in Windows for the network. You'll get access this way for sure.
 


#5
I already installed 4 updates for it from windows but ill look again. The routers mac adress thing is turned off and the router is running factory defaults.
 


#6
Right. That's why you should install from the motherboard site. Windows Update probably installed a bad driver for your network. It happens often. So installing the proper one will from the manufacturer will most likely fix the issue.

Or you could simply open device manager. Expand the network section. Right click on the NVIDIA one and choose properties. Then driver tab. Click on roll back driver.
 


#7
Ok how do I find out what which one to download I know I have a Nvidia nforce networking controller but I dont know which one?
 


#8
Use CPU-Z to find out which motherboard you have. It will tell you on the mainboard tab. Then visit the manufacturer's site page for the motherboard which will have the NVIDIA driver available to download. Make sure to get the one for x64 (64 bit).

CPUID - System & hardware benchmark, monitoring, reporting
 


#9
This didnt work do you have anymore suggestions?
 


Last edited:
#10
Ok apparently I fixed. If anyone has ever had this problem if you turn off you computer unplug your computers power cord then plug it back in. For some reason that worked.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.