No IPv4 or IPv6 Connectivity - Adapter installed, network not found

Discussion in 'Windows 7 Help and Support' started by MBowen, Jan 22, 2013.

  1. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    Recently had BSOD upon launching browser. Deduced scan for network from Netgear Smartwizard WAN adapter was the last thing initiated before BSOD. Learned that if I disabled the wizard before launching browser, no BSOD, connected fine. After a few days, I decided to fix it. I uninstalled all Netgear references, downloaded latest driver, it would not install. Several attempts later, I bought a new WAN adapter, same thing. Spent an hour with tech from Netgear, no joy. In Device Manager, the adapter shows as running fine and enabled. In Network Sharing, it shows as disabled, and will not enable. After running diagnostic, I learned that IPv4 and IPv6 were not connecting. My home network is not showing up in scans. Another wireless desktop in the house is working fine. The adapter works fine on another computer.

    So far, I have rebooted everything. I have reset stacks, flushed dns, reset winsock. I attempted to launch in safemode, but got a Windows Installer error. I reinstalled Windows Installer, but have not gone back to safe mode yet. I have attempted two Google pages worth of resolutions with no changes.

    IPCONFIG.

    I am currently connected with ethernet and all is well. I have tried everything. The last thing was SCANNOW, which came back with nothing missing or corrupt.

    Any help at all is appreciated. Thanks in advance,
    Mindi B
     
    #1 MBowen, Jan 22, 2013
    Last edited: Jan 22, 2013
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Do you have a model number for your Wireless Adapter?

    Since it isn't showing up in the IPconfig readout, it is probably disabled.

    Have you tried uninstalling it in Device Manager, and checking the box that says "remove all drivers", then letting Windows find it again?
     
  3. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    I double checked. The device is enabled and "working properly" in Device Manager. I uninstalled the driver from there and Windows re-installed. No change.

    After re-reading, I just want to be clear. I am no longer getting BSOD. The problem now is that the adapter is installed but cannot see the network, or connect to it. I have no wireless. Everything else is fine. Also, I have installed all available Windows updates.

    Thank you for the help.

    Oh... the current adapter is the original, WG111v3. The new adapter, that also failed, was WNA3100. I only put the old one back in because the adapter does not appear to be the problem, so the new one gets returned.
     
    #3 MBowen, Jan 23, 2013
    Last edited: Jan 23, 2013
  4. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    So it shows in device manager as working ok but does not show in network and sharing centre under adapers nor in ipconfig listings?
    It is worth disabling IPv6 btw - it is not currently being used and has been associated with some problems.
     
  5. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    Yes, it shows in Device Manager working ok. It does not show in Network and Sharing until I click "change adapter settings." I have included pics of "properties" and "status." I thought I had disabled IPv6, but I see that it's not. I've tried with that change, and also with all firewalls and anti-virus disabled.
    Properties. Status.

    Thanks in advance...
     
  6. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Check that the wireless channel is correct (maybe compare with the wireless connection that is working). Also, is the router transmitting its SSID?
     
  7. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    Two other desktops in the house are running their wireless fine. I assume then that the SSID is transmitting, although I can't see it on mine.

    Can you please be more specific about checking that the channel is correct? When the Netgear Smartwizard opens (it did finally install) I see it scan through many channels with no luck. Is there something else I should do with channels?

    Also, I am currently using WPA2-PSK [AES] security on my router, but disabling it was one of the first things I tried.
     
    #7 MBowen, Jan 23, 2013
    Last edited: Jan 23, 2013
  8. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    If the adapter is scanning all channels then that shouldn't be a problem but if you could check the setting for a working adapter and then manually set the problem one to the same.

    If the router is not transmitting its SSID you could have problems detecting it - you will either need to confirm that the router is set to transmit it (probaly easiest and best way) or the adapter is manually configured specifically to identify and connect the router SSID.
     
  9. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    In my router's UI, the box for "enable SSID broadcast" is checked. I have checked another adapter and set the channel to 11 to match. Not sure it matters, but the SmartWizard will no longer launch.

    Thanks again.

    Also, I attempted to add the network manually. After clicking "add" I was shown "An unexpected error occurred." This, before I even saw my network anywhere.
     
    #9 MBowen, Jan 23, 2013
    Last edited: Jan 23, 2013
  10. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
  11. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Maybe Pat will agree, but if your adapter does not show in ipconfig, it is not basically enabled. If it were just not connecting, it would show some basic substitute IP address.

    You don't really need the software that sets up the adapter. Perhaps it is causing problems. You can type ncpa.cpl in the Start menu box and get the adapters window. Go to properties and then IPv4 properties to see how it is set up.

    The troubleshooting guide first asks if the LED is on, and if so, is it blinking?

    Have you tried switching USB ports?

    You are also not showing any signal strength on your attachment.
     

    Attached Files:

    #11 Saltgrass, Jan 23, 2013
    Last edited: Jan 23, 2013
  12. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    Yes, it is. Also, I have the install disk for the adapter, and tried that. Also, I attempted earlier versions of the driver (1.5 I think?) with no luck.

    Just now I had the ISP reset the connection - or whatever it is they do remotely - also, no luck.
     
  13. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    Yes, both are set to automatic. I have posted a copy of my "status" window above; I have zero signal strength. The LED blinks twice when inserted, but does not stay on.

    I agree, it is more than just not connecting. Something is preventing it from getting that far. When I was using the WN adapter, it was enabled in Device Manager, but not in Network Sharing. When I attempted to enable it from there, it would not. Click and nothing happened. As for this adapter, all the behaviors are the same, just a few different words or descriptions. It plugs in, it reports as fully functional in device manager, and yet... it's not. And again, this adapter works in the computer on the other side of the room just fine.

    Thanks again,
    Mindi

    Oh... yes, have tried three different USB ports.
     
  14. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    The problem is not with the isp. Ipconfig will list all enabled devices whether connected or not so the problem is definitely limted to your hardware/usb interfaces/drivers. Even with no connection at all to the router it would show in ipconfig with an IP address starting with 169 which the TCP/IP stack assigns in a process called auto-configuration in the absence of a manually or dhcp assigned address. The fact that it is not listed at all says "hardware/driver problem.
     
  15. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Furthermore the fact that another device showed the same problem tends to point to a problem with the usb interface.
     
  16. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    I'm going to sound a bit naive here, but if it's not the adapter - and it's not, because it works elsewhere - what hardware can be wrong? My ethernet connection works fine. I'm using it now.
     
  17. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    Is it fair to assume that there is a piece of hardware or firmware somewhere that would be skewed such that USB works for some devices, and not for wireless adapters? And would it be all ports? And is that something I can fix; a new USB driver? Don't laugh - I learn as I go :)

    Mindi

    I'm asking because my flash drives still work with the USB ports. Also, this is the first time in ten years I couldn't fix my computer by myself (only because I'm good with Google, not because I'm a wiz). I would have already just reinstalled Windows, but I would rather learn about this for next time. Flash BIOS, perhaps?

    Thanks again
     
    #17 MBowen, Jan 23, 2013
    Last edited: Jan 23, 2013
  18. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Try uninstalling all software relating to the adapter using "programs and features" then deleting the adapter from device manager. Remove the device, reboot, plug in the device and see if Windows recognises and installs drivers for it.
     
  19. MBowen

    MBowen New Member

    Joined:
    Jan 22, 2013
    Messages:
    38
    Likes Received:
    0
    I did as you suggested, and yes, it installed. It is currently in device manager, enabled.

    I wasn't trying to sound like a jerk, btw. Just feeling a fool for not knowing more about USB. I sincerely appreciate all the help I'm getting here.

    Also, there is a series of events that keeps nagging me. I believe it's in original post, but what could have been going on such that I would blue screen on launch of a browser, but only if the adapter software was scanning for a network? Once I disabled the scanning, and connected manually, I could launch the browser and the adapter worked fine. It was only after I tried to "fix it" by uninstalling and re-installing, that this nightmare began. Just throwing that out there.
     
  20. patcooke

    patcooke Microsoft MVP
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    May 16, 2010
    Messages:
    5,456
    Likes Received:
    268
    Best guess is that some code limited to the scanning process was causing the bsod. (There are some known issues between Win 7 ans some usb adapters).

    And all is up and running?
     

Share This Page

Loading...