No outgoing UDP Packets in Windows 7 Professional

Discussion in 'Windows 7 Networking' started by ryanrogan, Jun 21, 2010.

  1. ryanrogan

    ryanrogan New Member

    Joined:
    Jun 20, 2010
    Messages:
    12
    Likes Received:
    0
    Hi,
    I have an application running, where the clients contact a licensing server via UDP port 3047.
    The Clients run on Win2000, WinXP Prof. Everything works.
    Installed a Client on a Win7 box, tried to contact licensing server, no success.

    With tcpdump on the Serverside I see about 50 UPD packets per Request, arriving from the WinXP machines an NO packet coming from Win7 client.

    With windump on the Clients, same result: About 50 UDP-packets/Request leaving WinXP client, and not a single one leaves Win7 machine.

    DNS resolving (UDP 53) on Win7 box works. Connectivity to other hosts works, Internetaccess OK.
    Disabled Firewall and Anti Virus.

    Is Windows 7 filtering/blocking HIGH UDP PORTS somehow? Any other ideas?
    Thank You for your input.

    Ryan
     
  2. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Hey.

    Try running the app in compatibility mode for XP SP3 and then see if the UDP packets are actually being created/sent by it.

    Worth a look I suppose, because especially with the Windows Firewall off, I don't think there is any type of blocking going on at any level.
     
  3. ryanrogan

    ryanrogan New Member

    Joined:
    Jun 20, 2010
    Messages:
    12
    Likes Received:
    0
    Hi,

    thanks, but is there something else I can do, to nail down the problem? Why make the debug-environment more complex, than it is already?

    The question for me is, wether a Windows 7 Host (and not a virtual machine running XP) can send high port UDP packets, and what I need to do for that.

    Thank You,
    Ryan
     
  4. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Surely, you're welcome.

    I honestly don't see this potential test experiment I proposed, which would take probably about 20 seconds to setup, as complex.

    If UDP packets are being sent while running in XP SP3 compatibility mode, then you can be sure there is some fault with the app under Win 7.

    If UDP packers are not being sent still, then it is a positive sign the app itself is not at fault under Windows 7.

    To answer the question, to the best of my knowledge, of course Windows 7 can send UDP packets amongst all available 65536 ports. I have never seen anything that would say it is restricted by any means.
     
  5. ryanrogan

    ryanrogan New Member

    Joined:
    Jun 20, 2010
    Messages:
    12
    Likes Received:
    0
    Hi,

    I have additional information concerning my case, which I have not mentioned before:

    The Client App (the .exe file), which searches for the remote licensing server is located on a remote machine, which I acces via a share.

    So I start an .exe program from an remote location (there pops up this security warning about unsecure remote programs). Does Win7 restrict such "UNtrusted Programs" from opening high ports perhaps? Please point me to the right documenation, if I missed something since WinNT ;-) .

    Installed the client app locally (.exe file on local harddisk), and it worked like designed. Is there a way to define remote .exe programs as "not evil", to allow them to do "nasty" things like open hight ports? (Up to now, the source of the problem is just a theory of mine, perhaps someone can confirm, or
    not. Thank You.
    Ryan

    PS @TorrentQ
    Downloading VirtualPC and 2 patches: about 2 min. . installing: about 2 min. . Startet Win comatibility mode setup: ended up in Blue Screen : IRQ_NOT_LESS_OR..... .
    Honestly, dont want to bash Win7, but then I thougt, I want to solve my main problem, not the Win xp comp mode problem. Anyway thanks for Your input.
     
  6. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    I apologize for not explaining what compatibility mode is. It doesn't involve anything to download.

    All you need to do is right click on the .exe in Windows Explorer. Choose properties then compatibility tab. Check the box for "Run this program in compatibility mode for" and then set the dropdown to say Windows XP (Service Pack 3).

    Then try your app.

    Could you possibly attach a screenshot of the popup you're talking about? A visual of it may jog some form of memory for myself or others.
     
  7. ryanrogan

    ryanrogan New Member

    Joined:
    Jun 20, 2010
    Messages:
    12
    Likes Received:
    0
    Hi,

    here is the popup; well, not the real popup. I copied and paste it from somewher, but to give You an idea its OK I think.

    I know this Security warning already from XP machines, but on XP machines the started program behaves normally (UDP port wise)

    [​IMG]View attachment 6714

    Ryan
     
  8. ryanrogan

    ryanrogan New Member

    Joined:
    Jun 20, 2010
    Messages:
    12
    Likes Received:
    0
    Hi,
    @TorrentG
    tried context-menu of remote .exe file | properties | Compatibility: was not able to set Compatibilty mode permanent (everything greyed out), because app is on a network drive )):-(
    tried context-menu of remote .exe file | deal with Compatibility problems (third menu entry from top): applicaton did not even start.

    Sorry, I have german Win7 here, so I have to translate the menu entries.

    For me the main question is, is a remote application by default restricted in what it can do on the local machine?

    Edit:
    All Tests are done as local Administrator

    Thanks, Ryan
     
    #8 ryanrogan, Jun 23, 2010
    Last edited: Jun 23, 2010
  9. ryanrogan

    ryanrogan New Member

    Joined:
    Jun 20, 2010
    Messages:
    12
    Likes Received:
    0
    Hi,
    let me rephrase my question.

    What could be the reason, that an .exe application, started from the local harddisk, is able to send UDP packets, and _the_same_ application, started from a remote network share, is not?

    Any help would be appreciated.

    Ryan
     

Share This Page

Loading...