No printers in XP Mode

Discussion in 'Windows 7 Help and Support' started by blockie, Jul 16, 2010.

  1. blockie

    blockie New Member

    Joined:
    Jun 3, 2010
    Messages:
    14
    Likes Received:
    0
    It was my understanding that the availability of printers to programs in XP Mode would be seamless, This morning I tried to print from WordPerect 12 installed in XP Mode and there were NO printers I tried Quattro PRo and Microsoft Word, all in XP Mode, with the same results.
    Cannot remember if I was ever able to print in XP Mode as I put it in only a couple of weeks ago. And. YES, these programs were installed while I was in XP Mode.

    Update to above.

    Been playing with this thing all day.Discovered that one of my printers was a shared printer in XP Mode. Also found out that if I used it in XP Mode it was unavailable in Windows 7. Then I discovered that if I turned integration off the printer was no longer shared but then could be attached.Then I found out that the printers must be attached each time the virtual machine starts in XP Mode. That is unsatisfactory.

    Seems I am just fumbling around and not knowing if the printers can really be seamless or not.

    Bill
     
  2. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    XP Mode shouldn't print in Windows 7 if there are no printer drivers available. In order to print from Windows 7, you need a Windows 7 printer driver...installing the printer in XP Mode is fine, but it doesn't solve the issue of printing directly in Windows 7, no driver no print.

    Open your printer window and click add printer. Select local printer and uncheck the automatically detect printer checkbox. Click next and under the port selection you will see a list of ports. ex: (Yourcomputername:pRNX). Select the appropriate port. It will then ask you for the drivers.

    But I read about a way to do this without drivers:

    Go into your XP system
    Add LOCAL printer
    Add new port Type LOCAL
    Local port name \\yourw7machinename\printersharename

    You'll get prompted to insert your disk to add the driver for your printer (the XP one) although if its a common printer the XP system will have it anyway.

    Just make sure you enable Networking in your XP mode vm and have printer / file sharing enabled on the Windows 7 system.

    (Printer is the available on BOTH machines -- no shared drivers are necessary).
     
    #2 zvit, Jul 16, 2010
    Last edited: Jul 16, 2010
  3. blockie

    blockie New Member

    Joined:
    Jun 3, 2010
    Messages:
    14
    Likes Received:
    0
    ZVIT,
    "
    Go into your XP system
    Add LOCAL printer
    Add new port Type LOCAL
    Local port name \\yourw7machinename\printersharename"

    I did the above. Used \\WILLIAM-PC\KODAK
    The share name was already setup.Workgroup was named WORKGROUP on both W 7 and in XP-Mode
    Network was ENABLED
    Got the error "Network Path Not Found" when I entered \\WILLIAM-PC\KODAK
     
  4. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Turn off any firewalls for debugging. (ZA, Mcaffe, Norton, etc) If the firewall is the problem, you'll have to configure it to allow access to "trusted zone" addresses. Note that some firewalls must be completely uninstalled to stop them from affecting your networking. This should be done on both computers.

    See if TCP/IP Netbios helper is enabled.

    Try this free test to see if the Network is the problem:
    Windows Network Problem Solver

    Check this page. It seems to have your problem:
    Windows 7 :: XP Mode Error: A Duplicate Name Exists On The Network
     

Share This Page

Loading...