No second HDD in Explorer

Discussion in 'Windows 7 Help and Support' started by Tak3, Jan 14, 2009.

  1. Tak3

    Tak3 New Member

    Joined:
    Jan 14, 2009
    Messages:
    6
    Likes Received:
    0
    Have installed Windows-7 64 bit on my new 320GB HDD.
    Have two HDD spindles, however, the Explorer does not show the second one.
    Device driver does.

    How can I fix this?
     
  2. Moosetek13

    Moosetek13 New Member

    Joined:
    Jan 10, 2009
    Messages:
    282
    Likes Received:
    5
    Go into Disk Management and assign a drive letter to that partition, then it will show up in Explorer.
     
  3. Tak3

    Tak3 New Member

    Joined:
    Jan 14, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks, but,,,

    Went into /control panel/Storage/Disk Manager/. Found the drive that does not
    have drive letter assigned.
    Tried to assign, the default was "H" which is the next letter of all used.
    The message box said something like "This letter is used. Reset the letter anyway?"
    Did it, but it was rejected.

    My next option was to assign "I". the Response was "Invalid parameter".

    There seems no way to give a letter.
     
  4. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    Go into device manager and ensure that the device got installed correctly. Many times the problem is a bad driver that shows the device exists but wont let you access it. I am gonna suggest look for the most up to date driver.

    Another suggestion would be to try more drive letters and see if for some reason they dont want you using the drive I. Let me know what you find out.
     
  5. Tak3

    Tak3 New Member

    Joined:
    Jan 14, 2009
    Messages:
    6
    Likes Received:
    0
    Ooops,

    The letter "H" appered after a couple of minutes, on Explorer.
    Thanks anyway.
     
    #5 Tak3, Jan 14, 2009
    Last edited: Jan 14, 2009
  6. iroken22

    iroken22 Extraordinary Member
    Premium Supporter

    Joined:
    Nov 10, 2008
    Messages:
    1,649
    Likes Received:
    49
    Glad to hear we solved your problem. Once again welcome to the windows 7 forums.
     

Share This Page

Loading...