No second HDD in Explorer

Tak3

New Member
#1
Have installed Windows-7 64 bit on my new 320GB HDD.
Have two HDD spindles, however, the Explorer does not show the second one.
Device driver does.

How can I fix this?
 


#2
Go into Disk Management and assign a drive letter to that partition, then it will show up in Explorer.
 


Tak3

New Member
#3
Thanks, but,,,

Went into /control panel/Storage/Disk Manager/. Found the drive that does not
have drive letter assigned.
Tried to assign, the default was "H" which is the next letter of all used.
The message box said something like "This letter is used. Reset the letter anyway?"
Did it, but it was rejected.

My next option was to assign "I". the Response was "Invalid parameter".

There seems no way to give a letter.
 


iroken22

Extraordinary Member
Premium Supporter
#4
Go into device manager and ensure that the device got installed correctly. Many times the problem is a bad driver that shows the device exists but wont let you access it. I am gonna suggest look for the most up to date driver.

Another suggestion would be to try more drive letters and see if for some reason they dont want you using the drive I. Let me know what you find out.
 


Tak3

New Member
#5
Ooops,

The letter "H" appered after a couple of minutes, on Explorer.
Thanks anyway.
 


Last edited:

iroken22

Extraordinary Member
Premium Supporter
#6
Ooops,

The letter "H" appered after a couple of minutes, on Explorer.
Thanks anyway.
Glad to hear we solved your problem. Once again welcome to the windows 7 forums.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top