No svchost running at all

#1
Yesterday, I installed Foxit Reader, then decided I didn't like it. When I attempted to re-install, I received the error message that "the windows installer service could not be accessed." It was listed as running in the services applet of administrator tools, but would not work.

While then exploring the system, I found other things that wouldn't work--for example, audio, which is what put me on to the same problem last May--and others. I got many "class not registered" errors. SFC won't run. When booting to the CD and running SFC, I got the old message about a pending repair, although I can find no trace of one. Ran malware scanners, of course, and the system came clean. Clean boot was not useful.

The most significant thing I have found, which is probably at the root of this, is that in task manager, there are no instances of svchost running, unlike the usual ten or fifteen that normally run.

I had this problem in May, and ended up doing a complete re-install of Windows 7 Home Premium. I would like to avoid going through that again. It's difficult with visual impairment.

There is one potential similarity to now and the situaton in May, other than the symptoms described above. In May, I had tried installing a new nvidia card, which Windows wouldn't recognize, so I took it out and when I booted back to Windows, the above symptoms appeared. Yesterday, I saw in event viewer a dcom error, which traces back to the nvidia updatus "user."

Thoughts?
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Running SFC from an offline condition needs special additions to the command. I do not remember exactly, but you have to tell it where the Windows folder is and something else it. I will check and post back when I find it.

Most folks would probably suggest you run an anti-virus, and several of us like Malwarebytes. Something appears to be corrupting your system, but it might be a memory/hard drive type of situation.

Edit: This Microsoft site talks about running SFC and has an example of the offline command syntax. You must remember, the drive letters for the windows directory may not be the same as in Windows, for instance what you think is C: might be D: offline. The /OFFBOOTDIR and /OFFWINDIR switches should probably be used, but I have not yet tried it. Maybe I will later.
 


Last edited:
#3
Thanks for your reply. I ran a/v and anti-malware, and MS security essentials was running at the time. When I ran SFC I used the command-line parameters.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
It looks to me like you are a good candidate for a Repair Install. The unknown is what might be causing your system problems and will it survive the re-install.

Do you have an install DVD so you can load it from within Windows 7 and do an update install?

Also, I just tried running SFC from offline with C: showing as my windows partition and I was in C: when I started.

If I used SFC /scannow, I got the system repair pending message. When I ran it with the following command, it completed successfully. I do not have your current situation, however.

SFC /scannow /offbootdir=c:\ /offwindir=c:\windows

I had verified C: was the windows directory and there is a space between \ /. If you feel like trying, let us know.
 


#5
SFC /scannow /offbootdir=c:\ /offwindir=c:\windows

That's what I did. Sorry that I didn't make it clearer. Yes, I have an install CD. But the last time I tried repair install from within Windows it just generated error messages.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
It seems like your options are running out. If you can't repair, and you can't do a repair install, you may have to do a custom install.

If you are running SP1 and do not have an SP1 install DVD, perhaps removing SP1 prior to doing a repair install would help. I thought I tried that the other day and it worked with SP1 installed, but ended up with a non-SP1 version.

With your errors, I think I would reinstall and start over. If you can copy or move any of your data, it would help later, assuming it is not corrupted.

If you could afford it, perhaps installing a new hard drive and doing the new install there. You could at least test your system to see if some system problem was causing the errors. I would probably run a memtest on the system just in case that might be related.
 


#7
My error; I had not ticked the box to show processes for all users. Svchost is indeed running and multiple instances are listed.
Then that makes the whole thing even dicier.
Also, repair install won't work. Setup just reports that it can't find any disk information, and terminates.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.