Num lock keep turning on Randomly

sunnyk

New Member
My Num lock keep turning on Randomly. While I type something the numlock turn on automatically during typing. it uses U O key etc s forward and backward same for all keys for . make all my text spoiled and disturbed.
its been since 8 months I reset and formatted window twice nothing got corrected, also tried regedit Hkey to 0 2. nothing.

I am just few up with windows now, Anyone's solution will be quite helping...
 

MikeHawthorne

Essential Member
Microsoft Community Contributor
Hi

Normally the Num Lock key is on by default.
I've never seen mine be turned off, as far as I can remember.

The Num Lock key should only affect the keys on the Number Pad, when it's on, the keys type the Numbers, when off it types the other uses labeled on the keys, i.e. 7=Home, 1=End, 9=PageUp etc.

Take a look at this there is a section about why does the Num Lock key keep turning on...

What is a num Lock?

And info on how to have it turned off by default...

How do I disable or enable the Num Lock key at startup?

Mike
 

sunnyk

New Member
MikeHawthorne You are right, num lock turns the keys on right side to a different function. But my problem is that my numlock turns on randomly while I type something. even during typing when i dont see screen sometime it ruins my text when I num lock randomly turn on it self and i dont tae notice. I keeps happening with me since longtime even Ive reset the windows. And now I am hopeless and fed up of window....:confused:
 

helpifIcan

Fantastic Member
More likely to be a hardware related issue. Maybe something under the num lock key or just a bad key. If a desktop have you tried another KB, if lap top not much you can do.
Might try a Linux distro and see if it continues if yes then defiantly a hardware issue. You run these with out installing.
 

nmsuk

Windows Forum Admin
Staff member
Premium Supporter
Check any power options, some laptops do this and the setting should be in your power util for the laptop.
 

sunnyk

New Member
helpifIcan can t be a hardware issue, as numlock on my keyboard needs to press two buttons at time, fn+numlk .. if there be a bad key how can it press two buttons at time.
I also seen this issue with few people on internet but with no solution for anyone
 

Neemobeer

Principal Cybersecurity Architect
Staff member
Any application could programmatically toggle this. Try booting into safe mode and see if the problem goes away. If it does then I'd say an application is toggling it.
 

MikeHawthorne

Essential Member
Microsoft Community Contributor
I still dont quite get it, but I never use the numpad keys while I'm typing.
What keys that you use when you are typing are effcted by the Numlock key?

Do you use the Numlock keys to enter numbers when you are typing?

I assume this is a laptop, so you can't use another keyboard to see if that makes a difference?
 

sunnyk

New Member
MikeHawthorne Just like you I also didnt used numpad ever, instead I use the top keys row of number on keyboard.

But the numpad turn on unintentionally even during the typing, like when I use backspace or arrows and type i see my numpad is on and it messed up all my text I wrote before.

Its beyond my understanding whats happening with me..:confused:
 

sunnyk

New Member

Attachments

  • samsung_series9_laptop_keyboard_key.png
    samsung_series9_laptop_keyboard_key.png
    98.4 KB · Views: 354

sunnyk

New Member
lQ8ddLK.png
Here is what i found on a forum. Someone having this problem. It was due to the new mouse with extra tilt buttons that were not configured and was on numlock on default, solved someone else problem.
But in my case I dont have tilt button instead i have forward back double click dpi scroll buttons only.

Any idea about that?
 

lhemy

New Member
My Num lock keep turning on Randomly. While I type something the numlock turn on automatically during typing. it uses U O key etc s forward and backward same for all keys for . make all my text spoiled and disturbed.
its been since 8 months I reset and formatted window twice nothing got corrected, also tried regedit Hkey to 0 2. nothing.

I am just few up with windows now, Anyone's solution will be quite helping...
This is happening regularly on my Logitech keyboard, driving me nuts. Then I cannot shut off the number lock for a few moments and it completely stops me from being able to work. It keeps going on by itself, I never hit that key.
 

ussnorway

Windows Forum Team
Staff member
Premium Supporter
This is happening regularly on my Logitech keyboard, driving me nuts. Then I cannot shut off the number lock for a few moments and it completely stops me from being able to work. It keeps going on by itself, I never hit that key.
step 1 = replace the mouse

the joy of a gaming mouse is that you can program them but the issue is also that they can be programed
 

AdrianG001

Senior Member
What is the exact make and model?

Open Start, type: system information
Hit Enter
Click System summary
Look in the right pane

Copy the system sku info into reply here.

See example:
Its possible you might need a BIOS or Chipset driver update to resolve this issue.

Other options you can try:

Reset BIOS default:

Turn off the computer and wait five seconds.
2. Press the Power button to start the computer and repeatedly press the F10 key to enter the BIOS setup menu.
3. On the BIOS Setup screen, press F9 to select and load the BIOS Setup Default settings.
4. Press F10 to Save and Exit.
5. Use the arrow keys to select Yes, then press Enter when asked Exit Saving Changes?
6. Follow the prompts to restart your computer.
 
Top