Num Lock not responding on boot up

Discussion in 'Windows 7 Help and Support' started by ccbob, Nov 25, 2010.

  1. ccbob

    ccbob Active Member
    Premium Supporter

    Joined:
    Jan 6, 2010
    Messages:
    18
    Likes Received:
    0
    I have tried to get the Num Lock Key to set on boot up to no avail. I have edited the registry and set the Initial Keyboard to -2 with no response. I still have to set it manually after boot-up. I also tried with the Total Idea Tweak 7 to set Num Lock on boot up with no avail.

    After boot up I can set it manually and it stays set until I make a remote connection to the computer and have to log in again following the remote connection I have to reset it manually. I do not have this same problem in systems running Win 7 32bit and wonder if it has something to do with Windows 7 Ultimate 64bit.
     
    #1 ccbob, Nov 25, 2010
    Last edited by a moderator: Nov 25, 2010
  2. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    One soultion (may not apply to you):
    [ubuntu] Number pad keys not working (NUM lock is ON) - Page 2 - Ubuntu Forums

    2. Try settings in BIOS:
    1) Tap F12 to enter the Boot Menu
    2) Under the Boot Device Menu select System Setup
    3) In the left side of the screen expand the category POST Behavior
    4) Look for Num Lock Key option
    5) Hit Enter and make changes to Turn off or Turn on the Num Lock
    6) Exit and reboot the computer.


    3. From another user:
    I experienced the same problem myself; fortunately, the solution is simple. For some reason, the default value of some of the registry keys (not all) were changed in windows 7, which causes the system to apparently ignore the InitialKeyboardIndicators settings in the other locations. All that is requireded is the performance of a search of the registry using regedit for that key. It is important to use the find function to locate ALL keyboard keys forInitialKeyboardIndicators and set them to the same value setting. The value options are as follows:
    0 - Turn all indicators Off (NumLock, CapsLock, ScrollLock)
    1 - Turn CapsLock On
    2 - Turn NumLock On
    3 - Turn CapsLock and NumLock On
    4 - Turn ScrollLock On
    5 - Turn CapsLock and ScrollLock On
    6 - Turn NumLock and ScrollLock On
    7 - Turn all indicators On (NumLock, CapsLock, ScrollLock)

    In my case, the string value was some 7 or 8 digit number such as 21765430. These entries are the cause of the reboot change in the num lock status. If you want it on when you boot, set the string value to 2 in all the keys with numeric values. Problem solved!

    4.
    http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/8f604425-19c5-48f1-b70a-f61674e9e1f4
     
  3. ccbob

    ccbob Active Member
    Premium Supporter

    Joined:
    Jan 6, 2010
    Messages:
    18
    Likes Received:
    0
    Many thanks to all who provided help. All of the suggested items were done including search of the registry for all instances of InitialKeyboardIndicators and all were set to 2 with the exception of the binary value definitions but did not seem to make a difference. I am resigned to living with the problem for now but it is a real bummer.
     
  4. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Some places say to go to HKEY_USERS\.DEFAULT\Control Panel\Keyboard but really you need to change it to 2 at HKEY_CURRENT_USERS. Try that.

    Microsoft also gives a solution with a small script you can do:
    http://support.microsoft.com/kb/262625

    * Try to turn off the default numlock setting in your BIOS. That way, the OS will turn it on.

    * Another method that helped some:
    1. hit NumLock to have light ON
    2. press "Ctrl + Alt + Del"
    3. click Log Off from the drop down menu
    4. log back in and reboot for the test

    If this doesn't do it, then repeat above, but do a shutdown with it on
    and restart.

    Don't use the method through start menu. This is reported to have
    reset the startup of numlock.

    * I posted this above but here's a clearer version:

    1. Click Start, then click Run
    2. Open HKEY_CURRENT_USER\Control Panel\Keyboard
    3. Select the String InitialKeyboardIndicators
    4. Change the string value to the desired value as shown in the table below

    String Value Effect 0 All Keys Off 1 Caps Lock On 2 Num Lock On 3 Caps Lock & Num Lock On 4 Scroll Lock On 5 Caps Lock & Scroll Lock On 6 Num Lock & Scroll Lock On 7 All Keys On Restart your computer to see the effects.



    [​IMG]
     
    #4 zvit, Nov 28, 2010
    Last edited: Nov 28, 2010

Share This Page

Loading...