Occasional crash from TDI.SYS trying to enter Sleep mode

Discussion in 'Windows 7 Blue Screen of Death (BSOD)' started by Ninethe, Nov 18, 2012.

  1. Ninethe

    Ninethe Well-Known Member

    Joined:
    Nov 17, 2012
    Messages:
    51
    Likes Received:
    1
    About 20% of the time, my Win7 Home Premium 32-bit laptop system BSD crashes when I'm trying to put it into Sleep mode; the rest of the time Sleep mode works perfectly. It always crashes in exactly the same place: In TDI.SYS caused at location TDI.SYS+50E0. The Bug Check string is: "IRQL_NOT_LESS_OR_EQUAL", with a code of 0x0000000A. I can detect no pattern whatsoever as to when it crashes versus when it doesn't.

    The crash is essentially "hidden" from me because I expect the screen to go dark and it does so even when it crashes (i.e., I don't see the BSD, because the screen has already gone dark when it happens). I'm usually not aware it has crashed until I try to bring it out of Sleep mode and discover that the computer will not resume because it has completely shut down after the crash.

    My antivirus is Avira Desktop Premium 2012 (paid) with the latest updates. My Firewall is the Comodo free firewall. Neither seem implicated in the crash.

    I've attached all the information requested at "How to ask for help with a BSOD problem", but I've included additional info as well: Two output files from the BlueScreenView application: "BlueScreenView Crash Report Summary.html" and "BlueScreenView Additional Crash Stack Info.txt"

    My Profile shows some general system info, and the attached rar file has more details.


    Please help me out!View attachment W7F_17-11-2012.rar
     
  2. GeneralHiningII

    GeneralHiningII Honorable Member

    Joined:
    Sep 21, 2012
    Messages:
    745
    Likes Received:
    7
    Hi there, welcome to W7 Forums!

    From your SystemInfo.txt, it seems as though you don't have Windows 7 SP1 installed. Please use these instructions: Learn how to install Windows 7 Service Pack 1 (SP1) to install SP1.

    You also seem to have a USB wireless adapter installed (Windows 7 doesn't like them):

    PHP:
    NETGEAR WNA3100 N300 Wireless USB Adapter
    Please uninstall that device through Device Manager or Control Panel (DO NOT SIMPLY DELETE IT IN THE DRIVERS FOLDER).

    There are 2 devices that could be problems in your system:
    PHP:
    HDA CX11270 Soft Modem        This device is disabled.
    Dell Wireless 1390 WLAN Mini-Card   This device is disabled.
    Please enable them or remove them from your computer.

    There appears to be a problem with Avira antivirus. Please uninstal both Comodo and Avira for the period of debugging and use Microsoft Security Essentials (link to download in my signature).

    Code:
    Analysis:
    Built by: 7600.16988.x86fre.win7_gdr.120401-1505
    Debug session time: Sat Nov 17 08:25:39.852 2012 (UTC + 11:00)
    System Uptime: 0 days 10:41:54.617
    BugCheck A, {0, 2, 1, 8249e2f9}
    *** WARNING: Unable to verify timestamp for scmndisp.sys
    *** ERROR: Module load completed but symbols could not be loaded for scmndisp.sys
    Probably caused by : scmndisp.sys ( scmndisp+1324 )
    BUGCHECK_STR:  0xA
    PROCESS_NAME:  System
    ¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
    
    scmndisp.sys is a driver signed by NETGEAR (coincidentally the manufacturer of the wireless USB Adapter, and putting 2 and 2 together, you can probably guess that it's the wireless USB adapter that's causing the problem.
     
  3. Ninethe

    Ninethe Well-Known Member

    Joined:
    Nov 17, 2012
    Messages:
    51
    Likes Received:
    1
    Thanks enormously, GeneralHiningII, sir! Your reply is most helpful.

    I'll return to the SP1 issue below, but first I have some questions I hope you have time to answer...

    That the Netgear wireless USB device and/or driver is at fault seem eminently reasonable, and I accept that. Unfortunately, I have no alternative to using a wireless USB device. You see, the computer in question is a laptop (Dell 1526), which I predominately use to play streaming video (to an attached HDTV), yet the laptop's built-in wireless device (the Dell Wireless 1390 WLAN Mini-Card mentioned in part of your reply) is essentially useless because of its very low bandwidth due to its lack of 802.11n capabilities (whereas the Netgear USB device is extraordinarily great for that purpose, the best I've ever seen). Also, I simply cannot afford to purchase a replacement laptop (and Rokus or other streaming video devices are unacceptable to me). I could try another manufacturer's device, but I don't see any alternative to some kind of wireless USB device, do you? (Stringing an Ethernet cable isn't practical).

    Also, might you elaborate please on your parenthetical comment that "Windows 7 doesn't like them"? Is that an acknowledged or otherwise well-known design flaw in Win7? Can you provide some links that discuss this issue?

    Moving on, you suggest enabling or removing two devices from my laptop. I'd like to remove them, but since they're both integral parts of the motherboard, physical removal is not an option. But if I uninstall their drivers, won't Windows keep trying to re-install them? Please advise me on this.

    I will happily uninstall both Avira and Comodo and replace them with Security Essentials during diagnosis.

    Now, returning to the SP1 issue, I've tried installing it approximately 75 times without success. It's been the single most frustrating software experience of my life (and I'm a systems programming veteran of more than 30 years!) I've run dozens of "Fix Its" and I've worked with Microsoft directly several times to try to resolve the problems, but the support agents have bailed on me every time (it seems like they're only allowed a small number of hours before their supervisors tell them to move on to the next customer).

    So at this point, I've decided to try a non-destructive repair install. Fred Langa updated his classic XP instructions for Win7 here: http://windowssecrets.com/top-story/win7s-no-reformat-nondestructive-reinstall, and what looks like your sister forum does so here: Repair Install - Windows 7 Forums

    I haven't decided whether or not to slipstream SP1 with it yet, but if I did so, at least I wouldn't have to worry about not being able to install SP1 later. Do you have any experience with this and any advice?

    Anyway, unless you have any viable alternatives to suggest to replace a USB wireless device, I may be stuck with this BSOD crash problem when entering Sleep mode...

    Thanks again for your time!
     
    #3 Ninethe, Nov 19, 2012
    Last edited: Nov 19, 2012
  4. GeneralHiningII

    GeneralHiningII Honorable Member

    Joined:
    Sep 21, 2012
    Messages:
    745
    Likes Received:
    7
    Do you have any Ethernet Cables for a cable link to your modem instead of using the wireless card? If not, you could probably pick up one at a local tech shop for a decent price.

    As for the comment "Windows 7 doesn't like them" - I can't exactly give you links to any sites (I'm fairly new to BSOD Analyzing, so I'm sorry if I can't help you on some things), but following usasma's (another BSOD Analyst in this forum) quote:

    Windows will most likely try to reinstall the drivers for the disabled part:


    if that doesn't work,



    As for the SP1 Installation:
    Fred Langa's Article looks to me as though it's simply a reinstall of Windows, not an update to SP1.
    The one from sevenforums looks like an option though, so why don't you try it out?

    To replace your Wireless USB Device, like I mentioned before, you can use an ethernet cable.

    Since I don't have a laptop, I'm not sure how to help you with that (but I'm fairly certain that there are cards that connect to the 4G/3G phone network for internet).

    Sorry if I disappointed you in anyway :uncomfortableness:

     
  5. Ninethe

    Ninethe Well-Known Member

    Joined:
    Nov 17, 2012
    Messages:
    51
    Likes Received:
    1
    Dear GeneralHiningII, sir!

    I apologize for my considerable tardiness in following up; I hope you will forgive me...

    You see, I was about to respond when a new and possibly related issue arose, but since the new issue isn't quite a BSOD I feel I should write up the new problem elsewhere on this forum, which I shall do later.

    However, I consider the original problem described in my OP to now be apparently SOLVED!

    And, to my great delight, replacing my USB wireless adapter was completely unnecessary! (As an aside related to your suggested alternative of laying an Ethernet cable approximately 200+ feet across my house, I explained in an earlier reply that "Stringing an Ethernet cable isn't practical", and simply isn't feasible. Also, the information on potential problems with wireless USB under Windows 7 you referred me to I now know to be strictly related to early Win7 users' problems with wireless USB device drivers that were designed for Vista or were otherwise premature. As of now, the end of 2012, to the best of my research there do not appear to be ANY remaining general problems using USB wireless adapters with Windows 7 as long as the driver and software are both Windows 7 compatible and of relatively recent vintage) However, in future responses to others who may find themselves in an otherwise insurmountable difficulties, a third option is to consider powerline networking).

    The solution to my OP was found in your recommendation to -- one way or another -- apply Service Pack 1. Because that failed me scores if not hundreds of times previously, as I proposed I performed a non-destructive re-install of Windows 7. (Note trying to use both slipstreamed SP1 and tying to use an install image that already contained SP1 failed utterly, because neither will permit a non-destructive re-install unless SP1 is already installed(!)). After that non-destructive re-install of Windows 7 without SP1 succeeded, I immediately applied the SP1 update, which also completed successfully - hooray!:thumbs_up:

    After that, I never experienced the problem described in my OP again, even without changing out my extraordinarily great Netgear WNA3100 USB wireless adapter!

    The last thing left for me to do was remove Microsoft Security Essentials (which I installed at your request), and then return my original commercial anti-malware and firewall software. HOWEVER, a few days before doing that, the new problem I mentioned started occurring IMMEDIATELY after applying the most recent set of Windows 7 updates from Microsoft. Sigh! :(

    The sole symptom of this new problem is that after those latest Win7 Updates (released and applied on Thursday, December 13, 2012), and ONLY after watching Netflix streaming videos for between 1 and 3 hours, my laptop just ups and powers-down suddenly and instantly, in less than 2 seconds flat! There's no warning and no indication whatsoever, no message, no visible changes, no blue screen, no crash log, no nothing! The laptop was plugged in and running solely on AC. The other device plugged in to the outlet (a Sony HDTV) did NOT power down, so I'm certain this wasn't a power failure. This has happened at least six times since Dec 13, and immediately after the first time, I installed two software temperature monitoring programs, and they both show that neither the CPU cores, the GPU cores, nor the disk drive temperatures were high in the least. The history showed the highest temp was when one of the CPU cores reached 71c, yet the manufacturer states the CPUs can accommodate up to 95c safely.

    I've run the laptop in normal Windows 7 mode with Firefox running but without watching Netflix for more than 24 hours straight with no problems at all, so there's nothing wrong with either Windows or Firefox. The sudden power-downs ONLY occur after watching Netflix streaming movies for a period of time, but note most importantly that this NEVER happened before the Microsoft update set of 13-Dec-2012, so there are strong reasons to believe that both Netflix streaming -and- one or more of those MS updates are interacting in such as way as to cause this inexplicable power-downs, but no heat problem is involved.

    The event logs don't appear to show anything obvious to me to explain this bizarre problem, but I'm no expert on Win7's event logging system. The one thing that looked potentially troubling to me was the vast number of repeated error message that reads as follows:
    When I looked that up, it turned out to be somehow related to Microsoft's Windows 7 Anti-malware system software. I then guessed that this might in turn be related to the Microsoft Security Essentials software I installed at your suggestion to replace my commercial malware & firewall software in order to isolate the problem described in my OP (above). Therefore, after a few days of experiencing these sudden power-downs, I uninstalled MS Security Essentials and re-installed my commercial products.

    Unfortunately, that made no difference at all. Thus, I have to write up a new OP to seek assistance on this new problem...


    Sorry if you found all that to be too verbose!

    In closing though, I wish to express my genuine gratitude for your kind assistance and knowledge, GeneralHiningII!

    I hope you enjoy your holidays!
     
  6. GeneralHiningII

    GeneralHiningII Honorable Member

    Joined:
    Sep 21, 2012
    Messages:
    745
    Likes Received:
    7
    Thanks for taking the time to find out the problem yourself, it's good that there are people like you who don't rely solely on advice given by people like me. We all make mistakes.May I make a suggestion?Give me a link to your new thread, if you have already created it - (I may be able to learn from the people who help you there, or etc etc etc).For the new problem you gave me:
    And you mention Microsoft Anti-malware. First: Microsoft's Windows 7 Anti-malware system software is not related to Microsoft Security Essentials - Microsoft's Anti-Malware come with Windows 7. How I would solve it:(Assuming you have the the option "Show all Hidden Files and Folders" enabled: Show Hidden Files and Folders in Windows 7 or Vista - How-To Geek use the instructions to enable that option)Go to -
    And there should be a file named "EppOobe.etl" (if not, we've probably found the problem [ie: if the file is missing - it shouldn't be, since you reinstalled Windows, but who knows?])Delete the file named "EppOobe.etl".Go to Recycle Bin, and delete "EppOobe.etl".Reboot your computer.Optional Step:Go to Start Menu, and type in "Event Viewer".Under the file "Custom Views", select "Administrative Events".You should now see a list of all the Events that happened, with either "Error", "Warning" or "Critical" in front of it.(Remember Event Viewer, as we will need it later on to see if the problem is fixed)Go back to C:\Program Data\Microsoft\Microsoft Security Client\Support\ and check to see that a new "EppOobe.etl" File is created. IF so, good! IF not, I'll get to that later as well.Retest the problem and see if your system still crashes. IF it does crash:Check Event Viewer to see if it's the same problem.IF it doesn't crash:Good!
     

Share This Page

Loading...