OnBoard Lan was broke: how could this have fixed it?

Discussion in 'Windows 7 Networking' started by MrActuary, May 18, 2010.

  1. MrActuary

    MrActuary New Member

    Apr 9, 2010
    Likes Received:
    I have an Acer Aspire M5700 desktop purchased in late 2009. Onboard Intel® 82567-V2 Gigabit Ethernet Controller. Originally came with Vista and upgraded to Win7 through Acer's free upgrade program. All features of the system were operating without noticeable issues until a few months ago. I put the computer to sleep/hiberate every night. Woke up one morning and noticed there was a blank screen I'd never seen before which simply read that there was a "fatal error" and that the system could not come out of hibernate and instead was rebooting.

    Note that pretty much immediately after this the internet stopped working and would state "Default Gateway unavailable" when I diagnosed and was only connecting to an "unknown public network". Everything about the NIC appeared to work: device manager seemed to say everything was running fine, drivers were updated and no hardware issues. Connectivity would always state no gateway connection and I wasn't able to ping anything. I know my ISP was working fine too because I could plug in my laptop to the wired internet and it worked perfectly. There was no router or wireless internet involved.

    Also I noticed that since this error, the system took significantly longer to boot up, about 2 minutes as compared to the previous boot time of 30 seconds. The computer would take a good 20 seconds before the monitor would "activate" with the light turning from orange to blue. Also, two new screens showed in the bootup menu that had never appeared before: one saying something about Intel Eaglelake technology with a message saying something like NOT AUTHORIZED TO DISMANTLE/ASSEMBLE and another showing a BIOS menu that was different from the previous BIOS display. After this the normal Acer screen appears that I had been used to seeing on bootup. One other issue that may have relevance. when I went into BIOS, the Onboard LAN was enabled and grayed out with no ability to disable it.

    So for months, I tried every software tweak I could think of to no avail. Eventually I cracked and installed a 10/100 PCI ethernet card in an empty PCI slot to test if the Onboard NIC was busted. All I did to install was remove the metal slot covering the PCI expansion bay, unplug the auxilary 4-pin power connector because the wire was in the way, insert the PCI ethernet card, and replug in the 4-pin power connector.

    I turn on my PC and immediately it reverts back to the "old" bootup process, the one that took 30 seconds. Win7 does NOT detect my PCI ethernet card but now when I try my onboard LAN, it works perfectly and internet is restored.

    So what the heck happened? Clearly there appears to be a correlation between the bootup time/menus displayed and whether my onboard LAN functions properly. Does anyone have any ideas?
    #1 MrActuary, May 18, 2010
    Last edited: May 18, 2010
  2. bassfisher6522

    bassfisher6522 Essential Member

    Aug 27, 2008
    Likes Received:
    As you stated, this is a hard one to pin down. I think I might have an answer for you. As you know intermittent problems are the hardest to solve especially ones that occur once a year or so for no apparent reason. My guess and this is and this is just a good guess, a power surge while in sleep/hibernate mode. I use to have an APC battery backup surge protector on my system. It use to get power spikes all the time and reak havoc on my system when it rebooted. I saw some similar screens as you indicated. So I removed it and not had a problem with it ever since. I still use a surge protector just no battery backup. I also found out that surge protectors can and do go bad even though all physical characteristics seem normal and that they should be replaced every 2-3 years. They are like any other piece of hardware on a system, whether that system be a media center or a pc setup and are most often then not over looked from system conception to system failure. Something the look in to.
    #2 bassfisher6522, May 18, 2010
    Last edited: May 18, 2010

Share This Page