One XP box sees Homegroup, but other XP box does not

Discussion in 'Windows 7 Networking' started by TomW, Jan 1, 2011.

  1. TomW

    TomW Well-Known Member

    Joined:
    Jan 1, 2011
    Messages:
    6
    Likes Received:
    0
    My home has four computers set up to share files & printers via a Windows 7 homegroup. Two computers are running Windows 7 Home Premium, and the other two are running XP Home. Everything works as expected with three of the computers. On the fourth, it is a one-sided conversation.

    The problem lies with one of the XP machines. Everyone in the homegroup can see his files and use his printer. He can see everyone but can only share files & printers with the other XP box. When he tries to see what is on a Win 7 machine, a “not accessible… you might not have permission message…” pops up even though the Win 7 machine he is trying to see has two shares (one requires password, the other does not) set up for the sole purpose of allowing XP boxes access to the homegroup.

    The network/work group settings on the two XP boxes appear to be identical. While I think there is a simple solution to this problem, I have yet to find it.

    What am I overlooking?
     
  2. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    Homegroup only works with Windows 7 machines. You'll have to set the network up the old way with workgroup on all.
    Joe
     
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    As Joe S has already said, there is no real benefit to be derived from using Windows 7 HomeGroups on a network with downlevel clients like XP Home. The old style workgroup settings will work just as well if not better, but since you seem to have indicated that you are seeing everybody ok from the other computers than I would suspect that the problem is more of a security issue than a network configuration issue. So first on the Windows 7 machines open the Network and Sharing Center and in the left column choose "Change advanced sharing settings"
    Make sure the following are selected
    Network Discovery Turn on
    File and Printer sharing Turn on
    Public folder sharing up to you I personally don't use it
    Media streaming again up to you
    File sharing connections 128 bit encryption should work fine, but if you still have problems after this go back and dumb it down.
    Password protected sharing Turn it on
    HomeGroup connections Use user accounts and passwords to connect to other computers.
    Now to make life easier for you overall, generally speaking avoid the temptations to use accounts with blank/missing passwords, you'll find that you will get better results if all user accounts have passwords and protecting network resources with passwords is generally considered a "Best Practice"
    Now just make sure that the username and password that you are using on the Win XP Home Machine is present on the two Win7 machines and that that account is a member of the appropriate group and the account/group has the appropriate share and ntfs permissions to access the share.
    Right click the file or folder and choose properties and define the permissions using both the sharing tab as well as the security tab to include the specific user or group.
    Should work
    Keep us posted.
     
  4. TomW

    TomW Well-Known Member

    Joined:
    Jan 1, 2011
    Messages:
    6
    Likes Received:
    0
    It did not.

    The XP machine (Jared) which was working fine with the setup continued to work fine, and the XP machine (Daniel) which could not see the resources on the Windows 7 machine (Tom) continued to not be able to see ANYTHING on Tom.

    When Daniel tries to connect to Tom, Daniel is never asked for a username/password. He is just given a "not accessible" message.

    Although Tom has made everything as easy as possible for anyone to access, not only can Daniel NOT access it, he cannot even see a list of inaccessible resources. Tom can use all of Daniel's resources, though.

    The odd thing is that while every computer involved is a Dell, Jared is the oldest & slowest of the bunch. I would have expected to have problems with him first.

    Even though Daniel's Event Viewer reports "all's well", to me all signs point to a wrong switch setting on Daniel. I wish I could find it.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Make sure that you can successfully ping Tom from Daniel by IP and machine name. Then consider any specific settings on Daniel that may be causing this issue. Specifically, third party programs, Firewalls, AntiVirus/Internet Security Suites, Network Management Utilities, etc. Uninstall them for the time being, don't attempt to disable or turn them off, won't do any good. Unistall them and re-install later when your network is working properly. If the problem was backwards I would suggest turning on the guest account on the XP machine, but as you've described it the issue must be on the Windows 7 machine.
    You receive an "Access is denied" error message when you try to access shares on a Windows XP Home Edition-based computer that is connected to a network
     
  6. TomW

    TomW Well-Known Member

    Joined:
    Jan 1, 2011
    Messages:
    6
    Likes Received:
    0
    The issue has been resolved, and it involved changes to the Daniel XP box.

    The 'Daniel' computer used by Daniel used to be Tom's (my children get my old computers). Although the computer name and user name were changed to reflect the trickle-down, I now wondered if the changes went deep enough.

    So a new user account was created on Daniel. After declining the automatic "Take a tour of Windows XP", I double-clicked on the Tom icon in network settings, and it finally asked me for a username/password.

    Daniel now has access to all Tom's resources.

    Thanks, all, for your help.
     
  7. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Excellent news. Good work, glad you were able to resolve your problem and thanks very much for posting back and updating your thread.
    Hope to continue to see you around the forums, stick around there's plenty of opportunities to learn and share your new found experience.
    Thanks Again
    Randy
     

Share This Page

Loading...