Windows 11 OneDrive sneaking into my filepath

rc hammer

New Member
At some point, very recently, my go-to folders (downloads, documents, pictures) found themselves in the path of onedrive. So instead of Users/Me/Downloads it's Onedrive/RandomDirectoryFrom3YearsAgo/Downloads. What's worse is now I have a mix. Documents has onedrive in the path, but videos is in the expected spot. WHen I go to properties of one of these folders, I have the option to reset the folder to its default location. But when I select that, that's when things really get screwed up. All sorts of permission errors which I've just come to accept I can't overcome.

I was not given the option while installing windows 11 to save files to pc locally (is that a new thing, cause it used to always be you could save locally). I have one drive turned off, but not uninstalled (I can't imagine what hell would be brought down on you for uninstalling it, you'd have your C drive under onedrive I bet).

Anyways, I suspect very intentional on Microsoft's part. And also very deceptive. The path bar at the top of explorer does not betray the fact you are in onedrive. You have to copy the path and paste it out to see what's really up.

Anyways is there a clean way to fix this? I'm not sure how I would avoid it even with a clean install.


And
 

rc hammer

New Member
Maybe the Videos folder is spared because they don't want to automatically back up files that large.

I dunno, I mean it's not the end of the world if I back it all up. It's just not necessary. My downloads folder is full of large files that I will only use once, like imaging a raspbery pi with some fun OS, I dunno. Why would I want that in the cloud, burning up my upload.
 

Mike

Windows Forum Admin
Staff member
Premium Supporter
Hello and welcome to the site,

Typically its going to rename your path from C:\Users\username\Desktop to example: C:\Users\username\OneDrive\Desktop or alternatively c:\users\username\OneDrive - Company Name\Desktop

Do you have anything else in the folder path? What you can try to do is this (but it will disable syncing of those folders):

You can change the OneDrive folder path for your Desktop, Documents, etc back to the default in Windows by following these steps:
  1. Open the OneDrive app.
  2. Click on the More button (three dots) and select Settings.
  3. In the Account tab, click on the Choose folders button.
  4. In the Choose Folders dialog box, uncheck the box next to any folder that you want to move back to its default location.
  5. Click on the OK button to save your changes.
  6. Wait for the files to sync back to the default location.
  7. Go to your user folder, you should see the files back to the original location.
Keep in mind that the above steps may cause the loss of syncing for the folders you uncheck, and if you have files in them, you will need to copy them back manually.

If you have installed Windows 11, you may also have the option to stop syncing specific folders from the settings of the OneDrive app, instead of unchecking them.
 

Muhammad Yosuif

New Member
Perhaps they don't want to automatically backup data that big, therefore the Videos folder gets spared.

If I back it all up, it's not the end of the world, I guess. Simply put, it's unnecessary. Large files that I will only ever use once, like imaging a Raspberry Pi with a fun OS, are all over my downloads folder. Why would I want something that will consume my upload on the cloud?
 

rc hammer

New Member
Hello and welcome to the site,

Typically its going to rename your path from C:\Users\username\Desktop to example: C:\Users\username\OneDrive\Desktop or alternatively c:\users\username\OneDrive - Company Name\Desktop

Do you have anything else in the folder path? What you can try to do is this (but it will disable syncing of those folders):

You can change the OneDrive folder path for your Desktop, Documents, etc back to the default in Windows by following these steps:
  1. Open the OneDrive app.
  2. Click on the More button (three dots) and select Settings.
  3. In the Account tab, click on the Choose folders button.
  4. In the Choose Folders dialog box, uncheck the box next to any folder that you want to move back to its default location.
  5. Click on the OK button to save your changes.
  6. Wait for the files to sync back to the default location.
  7. Go to your user folder, you should see the files back to the original location.
Keep in mind that the above steps may cause the loss of syncing for the folders you uncheck, and if you have files in them, you will need to copy them back manually.

If you have installed Windows 11, you may also have the option to stop syncing specific folders from the settings of the OneDrive app, instead of unchecking them.
Thanks for your reply. I'll try that out today. The peculiar thing about my filepath was it was like Onedrive\May2022\Documents. Where may2022 is a folder I created within my onedrive awhile ago, for an unrelated purpose

The other peculiar thing is that at least on one computer the paths switched over to onedrive without a recognizable trigger. Such that chrome, all of a sudden, couldn't download anything because it was aimed at the local downloads folder.

But I haven't tried changing the settings within onedrive, I'll try that.
 

ussnorway

Windows Forum Team
Staff member
Premium Supporter
the clean way to fix it is remove onedrive i.e, turn it off but yes Microsoft will reinstall/ change or replace it when ever they feel liike and you just have to put up with that as the price of using their software
 
Top