Open With Issue

#1
Hello all:

Running Win7 Ultimate 64Bit.

I recently installed adobe photoshop cs6. When viewing .jpg files in explorer they are associated with windows photoviewer. If I right click on a .jpg file and go to open with, the CS6 executable does not appear, so I select "choose default program", "browse", make sure "always use the selected program to open this type of file" checkbox is checked, go to the .exe file for CS6, select it, and it takes me back to the "Open With" window but does not allow me to select the OK button to make the association. It's like I never chose an .exe to open the file with.

Any ideas?

Thanks in advance.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Just to check your system, if you choose Paint to Open With, does it stick?

Have you rebooted since your CS6 install?

If Paint works, you might try going to the Start Menu, All Programs, Default Programs, Associate a file type or protocol with a specific program. If you can't set it there, it might be some type of access problem with that .exe file, but just guessing.

Are you sure you want to open Photoshop every time you need to view a .jpg?
 


#3
Hello all:

Running Win7 Ultimate 64Bit.

I recently installed adobe photoshop cs6. When viewing .jpg files in explorer they are associated with windows photoviewer. If I right click on a .jpg file and go to open with, the CS6 executable does not appear, so I select "choose default program", "browse", make sure "always use the selected program to open this type of file" checkbox is checked, go to the .exe file for CS6, select it, and it takes me back to the "Open With" window but does not allow me to select the OK button to make the association. It's like I never chose an .exe to open the file with.

Any ideas?

Thanks in advance.
You do not need to select the .exe file in browse option on Open with window. You need to select the shortcut icon given instead.
 


zvit

Honorable Member
#4
You do not need to select the .exe file in browse option on Open with window. You need to select the shortcut icon given instead.
It doesn't matter what you select. If you select the shortcut, the file association will redirect the association to the source exe anyway.

Are you sure that you are choosing the correct path which is:
C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Photoshop.exe?
 


#5
1) No I don't really want to open every .jpg with PS, but if I can associate them with the PS .exe so I can get the PS .exe to show up in the open with context menu, I can then later associate .jpg files with windows photo viewer again.
2) Pointing at a shortcut doesn't matter, and yes, I'm trying to grab the correct .exe file. I only installed the 64-bit version of PS, so there's no 32-bit .exe to point at by mistake.
3) Yes, I have rebooted since the install...several times. ;)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#6
So, it does or does not work with Paint?

When I go through your process, not CS6, my OK button is never greyed out. When does yours go grey or is it that way all the time?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top