Operating system not detected :-(

Hey guys,

So as in the title, when I start up my computer there's no OS being detected.

Reason being, I had upgraded from windows 7 to 10. Everything was fine, then I foolishly decided to give my computer a reboot, just to clean it up a bit. Halfway through, Windows 10 tells me there was a problem restoring it, so gives me a few options, one of them being to just turn my computer off. As I was in a rush to head into town and do some stuff, I chose to turn it off. I figured as that was an option given to me, it wouldn't have any negative consequences.

Obviously I was wrong, because the next time I turned it on... No operating system :-/

So I've read a few threads, watched a few videos relating to this issue, but non of the solutions are working for me.

I tried entering setup with F2, whilst my computer was loading. Then changed the order in which things boot. I.e; HDD first etc. Tried every possibility with no success.

I made some recovery discs when I first got my laptop. But how would I implement them considering I can't access Windows? Because it doesn't work putting the USB CD ROM option first in the F2 setup, boot menu.

I also have another, working laptop with windows 8.1 on it. Is there anything I can do using that to fix my broken one?

Any help advice would be much appreciated.


Success! Well, to an extent. Thanks anyway. Much appreciated.

However, I've encountered a few new problems. Firstly, its not the full version of Windows 10, as I required a registration key, which I didn't have. So I just skipped that section.

'Not a problem', I thought. As I was intended to revert back to Windows 7 anyway. However, it won't let me revert back to a previous build. My laptop, which is an Acer Aspire 5733, originally had Windows 7 on it. So I figured I'd be able to revert back to it. Something is amiss.

I'm also having a problem now, where when my laptop display goes off due to the energy saving option, it takes a while to come back on, then I get a notification saying my display driver was lost, but recovered. Or something along those lines.

So, I've tried a few things. Tried rebooting using my Recovery discs. Didn't work. Tried downloading the Acer recovery software to implement it, but it fails to download properly.

Once again, I'd appreciate some advice or info thanks.