Options to Pin to Task Bar and System Menu Have Disappeared!

#1
I am running Windows 7 Professional 32-Bit Edition with SP1. Somehow I have lost the "Pin to Start Menu" and "Pin to Task Bar" options when I right click on a program's icon whether it is running or not. Another strange thing is that when I right click on My Computer and select "Manage Computer", I get an error message that there is no program associated with that command. I ran "sfc /scannow" and it returned "Windows Resource Protection did not find any integrity violations." So I am at a loss. I do recall seeing an option to remove those privileges somewhere, but I cannot for the life of me remember which program I saw it in. So, help? (Hey! How do I insert a line feed into one of these messages?)
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
I do not know an answer for you entirely, but if you can open the registry editor, could you check to see if you have the entries highlighted in the attachment? Do not try to do anything yet, there may be an easier way someone else will know about.

I will continue to look, but for now, do you show any errors or warnings in the Event Viewer that might be related? Have you run any registry cleaning programs?
 


Attachments

davehc

Essential Member
Premium Supporter
#3
There is a significant reason , dating back to Vista days, for the fault, which might be your problem.. Have you used any hacks to remove the shortcut arrows on the icons?
If so, remove the hack again.
 


#4
Thank you, Saltgrass. I use Uniblue Registry Booster and CCleaner both to scan and clean the registry. I have seen nothing in the Event Viewer which would indicate a problem.
 


#5
Davehc, that is one of the problems. I HAVE used a hack, but I can't remember what it was. It is no longer on my machine, I know that, because I have looked at System Tweaker and cannot find the option there to do such a thing. I have nothing else installed which would allow that sort of change to be made (that I know of). I do not remember what utilities I have tried, there have been so many that I download and use for awhile before discarding as unsuitable for my type of computing.

Dang. This is frustrating. I used to have all my stuff in one sock, so to speak, and was really good with system configurations in Windows and a few flavors of Linux. Now I am not so sharp anymore and it shows when a situation like this arises. Dagnabbit.
 


Captain Jack

Extraordinary Member
#6
Davehc is correct. This happens on Windows 7 as well. You might wanna check it.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#8
If the suggestions about the Shortcut hack do not help or are not appropriate, we can get your items back if you are willing to work in the registry. Let us know.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.