Page Fault in Non-Paged Area BSOD, Now (Almost) Everything "Has Stopped Working"

Discussion in 'Windows 7 Hardware' started by Oblivious Sage, Oct 9, 2011.

  1. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Was playing New Vegas earlier today and suddenly got a BSOD. Error type was Page Fault in Non-Paged Area. My general approach is to just leave the machine off for an hour or so after a BSOD. Booted it up again a short while ago and was pleased to see Windows load and give me a login prompt. Logged in, everything seems fine so I close the "Windows has a recovered from..." message.

    I try to launch a program and it immediately tells me, "X has stopped working". Hmmmm. Try again, same result. Try a different program, same result. The following things do work: Notepad, Windows Explorer, Device Manager, Disk Management, command prompt. Windows Media Player Classic works until I ask it to actually play something. Everything else gives me the "X has stopped working" almost as soon as I launch it, including DXDIAG and right-clicking on My Computer and picking Properties.

    Since Disk Management worked I went ahead and ran the error checker on both my drives, they both came back clean.

    I noticed that all the "X has stopped working" messages gave essentially the same details (parts that are different each time are in italics):
    Problem Event Name: APPCRASH
    Application Name: whatever.exe
    Application Version: something.something.something
    Application Timestamp: 4xxxxxxx
    Fault Module Name: RPCRT4.dll
    Fault Module Version: 6.1.7601.17514
    Fault Module Timestamp: 4ce7ba59
    Exception Code: c0000005
    Exception Offset: 00039ab8
    OS Version: 6.1.7601.2.1.0.256.1
    Locale ID: 1033
    Additional Info 1: 0a9e
    Additional Info 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Info 3: (same as Add Info 1)
    Additional Info 4: (same as Add Info 2)

    Since they were all complaining about rpcrt4.dll, I grabbed my laptop and downloaded a fresh copy of that dll from dll-files.com. I changed the name of the old one to "rpcrt4 old.dll" and dropped in the new one. Problem persisted, so I used command prompt to run regsvr32 rpcrt4.dll and got an error message saying, "The module rpcrt4.dll was loaded but the call to DllRegisterServer failed with error code 0x80070006."

    Checked the BSOD sticky in the BSOD subforum here, the article there says "PAGE_FAULT_IN_NONPAGED_AREA" indicates (their words) "Faulty hardware, including RAM (system, video, or L2 cache)".

    How would I go about identifying which piece of hardware has failed?

    EDIT: Now I get that BSOD again every time I try to boot up. >_<
     
    #1 Oblivious Sage, Oct 9, 2011
    Last edited: Oct 9, 2011
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The BSOD forum would be the best place for such a question, but there is a sticky in that forum which describes what they might need.

    Until you check that, if you know you have a dump file, you might attach it and please use the .zip format.

    The file to which you refer is a Windows file and probably not the actual cause of the problem.

    Have you tried a Video Driver update or reinstall?
     
  3. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Now it gives me a BSOD every time I try to boot up, either that same PAGE_FAULT_IN_NONPAGED_AREA or a very brief (both in length and duration) ILLEGAL EXCEPTION one. That means I can't really get at all the dump files the BSOD forum needs, as well as furthering my suspicions that it's a hardware issue.

    Tomorrow afternoon I'll have some free time, so I'm going to try removing each of my memory sticks in turn, since that BSOD implies a memory error of some sort. If that doesn't resolve it reinstalling Windows will be my next step, and if THAT doesn't work then I'm probably looking at replacing one of my proc, mobo, or video card (and figuring out which won't be fun).

    Mainly hoping someone here might know a shortcut that will help me skip 1 or more of those steps via some easier form of testing.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    We still need the dump file, something there may lead directly to the problem. If you can't get the dump files, try booting into safe mode. You may be able to see a driver in the Device Manager that is having problems.

    The sticky tells you how to get one and how to attach it. But look in the Windows\Minidump folder. If a .dmp file there, attach using the paperclip on the Advanced Replies window. You could also get it in a Command Window if necessary.

    If you want to .zip it, just right click and send to a compressed (zip) file, then attach that file the same way.

    The dump file may show the actual problem, but even if it doesn't, it will show what drivers you are using and possibly one of those might be recognized as a problem.
     
    #4 Saltgrass, Oct 10, 2011
    Last edited: Oct 10, 2011
  5. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Like I said, it won't even boot up now (posting from my laptop). I'll see if I can get at the dump data via Knoppix, though.
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    May seem a stupid question at this point and I may have missed it in a previous post, but have you tried using the F8 key during POST to evoke the alternate boot menu and perhaps choosing safemode?

    EDIT: Sorry Clark, just saw that in your post above. My apologies.
     
  7. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    View attachment dmp from minidump.zip

    There's a zip of the file from Windows/Minidump. I used Knoppix to get it so I would need Linux versions of the SF Diagnostic and CPU-Z tools to get their data.

    F8 for safe mode also results in a BSOD while loading Windows.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, the dump talks about memory corruption.

    You do show one old file called AN983X64.sys (2005) which might be related to an infineon network adapter, hard to tell.

    If you cannot boot into Safe Mode to try to remove or update the driver, I would suggest you use Knoppix to try to rename it until you see if it might be the cause. It will probably be located in the Windows\System32\drivers folder

    Just a note, getting into Safe Mode might be a dance regarding when and how you use the F8 key. Tapping it at the right time, might allow a repair menu to be displayed.

    But I am not the BSOD expert here, so you might want to wait for some more opinions.
     
  9. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Regarding safe mode, I can get to the menu where you pick which version of safe mode you want. Picking normal safe mode (rather than safe mode with various other things turned on), it starts loading Windows but blue screens part way through.
     
  10. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I suppose this means if you pick a command prompt without networking it bluescreens?

    Also, if you can't get into a command prompt, you can't run the memtest and chkdsk utilities? Can't remember if one of these is on the F8 menu.

    Have you tried removing anything you can from the system for testing?

    Have you tried the "Last Known good configuration" option on the F8 menu?

    But if you are going to start replacing things, I would probably start with a new hard drive for a test install. You don't have to activate unless you want to keep it.
     
  11. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Haven't tried just the command prompt from safe mode, will give that a shot. Knoppix isn't letting me rename or delete that file; I seem to recall Knoppix can't write to NTFS formatted drives?

    EDIT: Safe mode with command prompt blue screens as well, with "Loading Windows/System32/CLASSPNP.sys" as the last step displayed. Last known good configuration loads for a bit then goes to a black screen and stays there; does not accept keyboard input (numlock key does not toggle numlock).

    EDIT2: While I was typing the previous edit, it automatically rebooted and went into Startup Repair. That ran for a while then produced the following error message: "The instruction at 0xfac345b5 referenced memory at 0x02d7c7e8. The memory could not be written." I have four 2GB sticks of memory so I'm going to try removing half of them and swapping them out to see if one of the sticks is bad.
     
    #11 Oblivious Sage, Oct 11, 2011
    Last edited: Oct 11, 2011
  12. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Still blue screens no matter which memory sticks are in there, so it's not the RAM. :( Was really hoping it would be, since that would be the easiest to replace.

    Any thoughts on how to proceed? Is it worth re-installing OS or is this definitely a hardware issue?
     
  13. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You may want to follow up your current memory diagnostic process by running MemTest86.
    Download and burn the bootable ISO (near middle of page) and run it, testing memory individually 5 to 7 passes, find a good stick and use it to also test individual slots
     
    1 person likes this.
  14. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Good idea, Trouble, I had forgotten it could be an issue with the slot rather than the sticks.
     
  15. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Very good idea, actually. Thanks, Trouble!

    MemTest immediately found corruption on one of the sticks, others seem to be OK. I still get BSOD when booting up, however, even if I try Last Known Good Configuration or Safe Mode. I guess messing with that .dll file may have messed it up somehow? I'll probably re-install Win7 when I have some time (Thursday most likely), unless somebody else has some ideas. Can't go back and fix the .dll since Knoppix can't modify files on an NTFS drive.
     
  16. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Were you able to boot into the command prompt without networking?

    If you did not succeed in changing the name of the network driver, it should not be involved, unless it was involved in the original problem.

    Also, the video card has memory.

    Maybe another dump file when not using the bad memory would help, if you can get one.
     
    #16 Saltgrass, Oct 11, 2011
    Last edited: Oct 11, 2011
  17. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Saltgrass, I don't see an option to get just a command prompt; I can pick Safe Mode with Command Prompt, but that apparently just launches Safe Mode then tries to pull up a command prompt once it's up.

    Will check for a new dump file tomorrow.
     
  18. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    The dumpfile in Windows/Minidump has the same name and is the same size as the one I posted before. Is it probably the same one I posted before or would a new dumplog likely have the same size and name?
     
  19. Oblivious Sage

    Oblivious Sage New Member

    Joined:
    Oct 29, 2010
    Messages:
    24
    Likes Received:
    0
    Re-installing Win7 fixed it once I removed the bad RAM; pretty sure I messed something up when I replaced that .dll file. Thanks all for your help, especially Trouble for the MemTest suggestion!
     
  20. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First on behalf of everyone involved, your welcome.
    And second, thank you for the follow ups and keeping us apprised of your progress. Sorry to hear that a Re-install was required but sometimes you're stuck with playing the cards you're dealt.
    Anyhow, thanks for joining our community and we hope to continue to see you around the forums.
    Regards
    Randy
     

Share This Page

Loading...