Partition not showing after installing Windows 7

Discussion in 'Windows 7 Installation' started by dabooj, Feb 9, 2010.

  1. dabooj

    dabooj New Member

    Joined:
    Feb 9, 2010
    Messages:
    10
    Likes Received:
    2
    Hi Guys,

    I had a test version of windows 7 installed on my Sata drive which had 3 partitions on it (c:40gb, d:40gb, e:220). This worked fine.
    I decided that i liked Windows 7 so i wanted to re-install it on a permanent basis so i went through the installation, formatted C: ONLY and installed windows 7 as a fresh copy. During installation, i noticed that c: & d: showed up correctly but e: was not showing. Instead, there was a 220gb unallocated space. I thoughht i'd ignore this as i have a lot of files on e: and i hoped that when i finished installing win7 on C: then E: would show up correctly.
    Unfortunately, this is not the case. I cannot see e: in my computer. When i go to disk management, i can see the 220gb space but no drive letter is assigned to it. Furthermore, when i right-click on the space, i cannot do any task (i.e. assign drive letter) except delete. Everything else is disabled. Also, the disk space being shown is size=218gb free=218gb.
    This looks like Windows 7 has decided to delete my drive without my permission. I have done absolutely nothing to the partition during or after installation yet i can't get it working.
    I had quite a bit of work on this drive and i was wondering:
    a) whether i can get the partition to work correctly on Win 7 without deleting/formatting?
    b) if i have to format the partition, is there a way i can get my data off the partition (if it is still there)?

    Regards,

    Shuja
     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Hello Shuja

    Welcome to the Windows7forums.

    It seems something went terrible wrong somewhere.

    Was this a clean install or an upgrade?

    Is it a purchased disk?

    If you E: partition shows as being empty, I doubt you can retrieve anything .
    I think your best bet would be to boot with a Linux Live ISO and see if you can find any information there.

    Download Linux Mint here:
    Download - Linux Mint

    If you find any info, you can copy it to a flash drive.
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Do you have just the one drive? A snipping tool picture attached of your disk management window might help.

    Until then, try this. Open an administrative command window. type Diskpart and hit enter.

    Type the following commands and hit enter after each. You can also type just the first 3 letters of each one.

    List Disk

    This should show you your drive/drives

    select disk 0

    If you only have one drive, use 0. Otherwise use the number of the drive you want.

    list partition

    Post back what this result is, then select the partition you want and

    select partition 3

    this is the 3rd partition on the drive.

    If you do not see the third partition, it does not bode well.

    If you have the third partition, try this

    assign letter=G

    pick whatever letter you want, but the DVD has a letter, and so might any external devices.

    Type exit and exit to close diskpart and close the window.

    The help file says you cannot assign a drive letter to a partition that has a pagefile. Yours should not, but since you can't see it, who knows.

    If none of this helps, you might download and burn the bootable Partition Wizard and boot to it to check the drive.

    All I might think is that something got messed up, as reghakr says.

    There may be a way to rebuild the partition table, but this might be dangerous. and since I have had no experience, I can't really say. I have not used this software, but something like this may be your only hope.
     
  4. dabooj

    dabooj New Member

    Joined:
    Feb 9, 2010
    Messages:
    10
    Likes Received:
    2
    SALTGRASS - I went through your instructions and when i got to the list of partitions for the drive in question, the 3rd partition WAS listed and had the correct size litsed too
    BUT when i tried to assign a letter to the drive i got a msg saying 'There is no Volume specified'
    I tried to list the volumes but i can't see the particular partition listed in the volumes.

    Any ideas?
     
    reghakr and (deleted member) like this.
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It sounds like you did not select the specific partition first.

    I would suggest you download and burn the Partition Wizard mentioned so you can look at the drive from outside of Windows.

    You can't assign a letter in disk management, so I am not sure if it is the partition that is having problems, or Disk Management. It sounds like the partition is still there, so maybe it can be recovered.
     
  6. dabooj

    dabooj New Member

    Joined:
    Feb 9, 2010
    Messages:
    10
    Likes Received:
    2
    Found the issue causing the problem.
    I tried the various solutions that have been mentioned but nothing seemed to work BUT i install the partition wizard software & when i viewed the disks within the PW, i could see the missing partition and i could explore the files.
    Now, for some reason, the partition had been set as a hidden partition (i'm not sure where this setting can be set). Within partition wizard i was able to unhide the partition.
    I could then go to windows 7 disk management & was able to assign the drive letter to the partition and the drive is working & my files are still on it.

    Thanks for all your help guys.

    Regards, Shuja
     

Share This Page

Loading...