PDF unable to copy between XP and 7 x64

#1
Laptop xp x32
Desktop 7 ultimate x64 new build

Logged in as administrator. I cannot drag a .pdf from my laptop (xp) over to my desktop (7). It says "you require permission from the computers administrator to make changes to this file". I've got "no security" selected in the pdf.

I CAN drag all sorts of other files over from this folder, so it doesn't seem to be a rights issue with the folder per say?

thx
 


Mitchell_A

Essential Member
#2
Hello, and welcome to the Windows 7 Forums.
How are you trying to drag files over? From within Windows (Windows Explorer "Network" section?)
 


#3
thx for the reply. Any which way I try and move something over. Either drag and drop, right click move/copy, or my preferred method, synchtoy.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
I have see that before, but I don't remember what I did to fix it. Maybe being the same user will help, or logging into the other computer might help.

Have you tried mailing it to yourself? Maybe if you take ownership of it in XP or make sure it is not read only. I think I found I could send a file easier that take a file from an XP install.

Are these .pdfs you made or were downloaded or sent to you?
 


#5
this is absolutely insane. In the xp computer (where the .pdf resides), there is no security setting or anything of the like in the file > properties. However from the 7 computer when you navigate to the file over the network (on the xp machine) and right click, there is all the security and ownership stuff. So it seems the 7 computer is looking for or has access to all sorts of other security stuff that the xp os does not have.???? logged in as full admin on both. a pdf I created.

on any of my xp files I do not see the security or ownership under the file > properties
 


#6
it's almost like I have to add my user account to the xp's machine for permission?

oh, this used to work just fine on the two xp machines before I "upgraded" one of them to 7:(
 


#7
Same Problem Here - Possible Workaround

Gang,

I purchased a new Windows 7 machine and received it late last week. Started copying files over my home network from my old XP to the new machine. Things went well overall, except for half of the PDF files on my system. Most of these were self-generated ... printing web pages (receipts, confirmations, etc) to PDF files. However, I did not see a pattern. While some files went over w/out issue, others did the "You need permission from the adminstrator to modify this file". Odd, since I was copying and not modifying.

I googled and asked around. I found this thread and others. I tried taking ownership of directories The Hard Way. I found that REG script that adds "take ownership" to the explorer context menu. None of this worked.

Via simple experimentation, I found that if I would SHARE the XP source directory containing the PDF files, the directory would copy over intact and with no errors. I did this for 3 large, previously problematic directories and they copied flawlessly.

NOTE that most of these directories were sub-dirs of an already shared "high level" directory. That didn't seem to matter. Perhaps if I would have re-shared the top dir and propogated all of the new settings down it would have also worked. However, I DO know that sharing the lower level directories fixed ths issue for me. One of these directories was partitioned in yearly sub-dirs, and sharing the parent directory allowed all the lower level context to be copied fine. Again, the SHARING was done on the source, XP, machine.

I'm not sure why only PDF files were a problem for me, but I now have all of my files copied over. One more pass through the old XP machine and I believe it will be ready for decommissioning, or perhaps reassignment.

Hope that helps!

Nick
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.