Permission/ownership problem

Discussion in 'Windows 7 Help and Support' started by Barry Gold, Feb 25, 2015.

  1. Barry Gold

    Barry Gold New Member

    Feb 25, 2015
    Likes Received:
    I have a desktop system that had WinXP on it. I bought a copy of Win7, put the install CD in the drive, and booted. After waiting a long time(*), it finally booted and offered me a choice:
    Complete install

    I'd swear I chose fresh install, but when it finished installing all my user files, etc. were still there.

    I went ahead and set up fourusers:
    barry (normal user)

    But when I started using the system, I discovered that all the old files were owned by "unknown" users. The result is that I can't write my own files. In some cases, not even the admin can write the files.

    This is a mess, and not very useful. For the time being, I'm storing new files on the external hard drive (where I had backed up all my user files before the install), but I don't want to do that permanently.

    I've tried using the admin user to change the permissions and/or the ownership, but that didn't fix the problem. Maybe I didn't do that right? The choices offered didn't seem all that obvious.

    So, how do I get out of this mess. My brain throws out two ideas:

    1. Start over: re-install, then install my apps again, etc. But *make sure* that I get a fresh install. Maybe do something (fdisk?) to make sure that my hard drive doesn't look like a Windows drive?

    2. One at a time, rename the existing user file directories, then create new ones and copy the contents of the old directories to them, then delete the old directories.

    Which do the experts here recommend? Or is there a better solution I haven't spotted?

    P.S. It appears that I have a 64-bit version of Win7 running on my 32-bit system. Is that going to cause a problem?

    (*) I could write an entire DVD in the time it took the install disk to boot!
    (+) I'd had a previous problem on a laptop where the registry got corrupted and the admin password was lost. I had to let the shop re-install from scratch. Every since, I've had two admin users, just in case.
  2. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Jul 22, 2005
    Likes Received:
    Hello, when you first did the clean install and your files were still there, it is possible that you did not clean the drive of its existing partitions. If you want to do a clean install, try to go back to the boot disk installation for a clean install of Windows 7 and remove all partitions before, leaving the disk "Unassigned" with no file system and then go through the installation process. This will ensure you are starting with a clean slate. Please note that your existing user files on the primary drive will be lost.

Share This Page