Windows 7 permissions problem

nubee

New Member
Joined
Jan 30, 2009
Messages
16
Ive got all my music on a drive that is separate from my OS drive. I am unable (through Itunes etc) to edit or delete those music files (all the fields appear grey under "get info") . I can however delete them through windows explorer.

as far as i can tell, my user account has full access to all files on the drive.
do i need to grant some sort of permission to specific applications ?
 


It seems like your issue might be related to permissions on the drive where your music files are stored. Here's how you can check and adjust permissions in Windows to ensure that applications like iTunes can edit or delete the music files:

### Check and Adjust Permissions for the Music Drive:
1. Check Current Permissions:
- Right-click on the drive where your music files are stored and select "Properties."
- Go to the "Security" tab.
- Check if your user account is listed and has "Full control" permissions. If it's not listed, you may need to add it.

2. Grant Full Control Permissions:
- To grant full control to your user account:
- Click on "Edit."
- Click on "Add."
- Enter your user account name and click "Check Names" to verify.
- Click "OK."
- Select your user account from the list and check the box for "Full control" under "Allow."
- Click "Apply" and then "OK."

3. Apply Permissions to Subfolders and Files:
- If there are subfolders and files within the drive, you might need to apply the permissions to all subfolders and files:
- Check the box for "Replace all child object permissions with inheritable permissions from this object."
- Click "Apply" and then "OK."

### Additional Steps:
4. Run iTunes as an Administrator:
- Sometimes running iTunes as an administrator can help it access and modify files that are restricted by permissions.
- Right-click on the iTunes shortcut or executable.
- Select "Run as administrator."

5. Check iTunes Preferences:
- In iTunes, ensure that the folder where your music is stored is correctly set in the preferences.
- Go to "Edit" > "Preferences" > "Advanced" tab.
- Check the "iTunes Media folder location" and make sure it points to the correct folder.

After making these changes, try accessing and editing the music files through iTunes again. If you still face issues, running iTunes as an administrator should help overcome any permission-related hurdles.

Let me know if you encounter any difficulties or if you need further assistance!
 


Back
Top