Please help - no internet?

Discussion in 'Windows 7 Installation' started by Chippy_boy, May 15, 2009.

  1. Chippy_boy

    Chippy_boy Senior Member

    Joined:
    May 15, 2009
    Messages:
    6
    Likes Received:
    0
    Upgraded my Vista Ultimate desktop PC to Windows 7 RC and everything works perfectly... apart from the fact that I can't get an internet connection.

    I have a wired ethernet connectio to my adsl router and the router is connected to the internet, as my laptop does still have access.

    The wierd thing is Windows 7 is talking to the router just fine. DCHP is working and it get's an IP address no problem and I can log in to the router. But the router <===> internet connection is broken.

    Anyone any ideas what could be wrong and how to fix it? I have tried disabling and re-enabling the network adapter and that does not work. I have also rebooted the router and that doesn't help either. I have searched for new network adapter drivers (Marvell Yukon) but the ones I have seem to be the latest.

    Any suggestions?

    Thank

    Well, I have managed to get it working by setting up a static ip address and dns servers and then going back to automatic settings, and it connected to the internet. Whether it will keep working after a reboot, who knows.
     
    #1 Chippy_boy, May 15, 2009
    Last edited: May 15, 2009
  2. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    Did you install the most recent Vista drivers or a Windows 7 specific driver? ;)
     
  3. Chippy_boy

    Chippy_boy Senior Member

    Joined:
    May 15, 2009
    Messages:
    6
    Likes Received:
    0
    I upgraded from Vista and 7 installed its own driver, which is later than the Vista one. I tried installing the Vista driver instead and it made no difference.

    The problem would appear to be something to do with DHCP not working properly. If I change to a static IP address and then change it back to automatic again, it fixes the problem.

    Funnily enough though, the static IP doesn't fix it itself. I still can't get an internet connection even with the static IP. It's only the change back to Automatic that fixes the problem.
     
  4. gjbnh

    gjbnh New Member

    Joined:
    May 6, 2009
    Messages:
    206
    Likes Received:
    2
    I have this problem to. I can get a wireless connection, but the OS only sees the local network on a wired connection; it doesn't foward packets to the internet. There doesn't seem to be any way to fix it, I will have to try your solution next.
     
  5. Chippy_boy

    Chippy_boy Senior Member

    Joined:
    May 15, 2009
    Messages:
    6
    Likes Received:
    0
    OK - I can confirm that for me, manually-entered IP address and DNS servers *does* fix the problem. I can now reliably boot up and surf the web.

    If I switch back to automatic, then the problem re-occurs and I have to fiddle about for ages to get the internet back again.

    For me, this is a workable fix.
     
  6. gjbnh

    gjbnh New Member

    Joined:
    May 6, 2009
    Messages:
    206
    Likes Received:
    2
    will HAVE to try this!! Thanks dude.
     

Share This Page

Loading...