Pls Help! Media center is killing me.

#1
I have Windows Home Premium. No matter what settings I choose in Autoplay, Windows Media Center opens every time I insert a DVD.

I've tried choosing "Take No Action." I've tried "Play with VLC." Doesn't matter. WMC autostarts every time.

Autostart options for other media such as blank DVDs work fine.

I've even gone so far as disable all Media Center services I can find in my "Services" list, and removed the Media Center "ehome" file from startup using msconfig as per the instructions here. But regardless of what I do WMC will not die.

It's driving me bonkers! Can anyone help? Please!!
 


#2
I have Windows Home Premium. No matter what settings I choose in Autoplay, Windows Media Center opens every time I insert a DVD.

I've tried choosing \"Take No Action.\" I've tried \"Play with VLC.\" Doesn't matter. WMC autostarts every time.

Autostart options for other media such as blank DVDs work fine.

I've even gone so far as disable all Media Center services I can find in my \"Services\" list, and removed the Media Center \"ehome\" file from startup using msconfig as per the instructions here. But regardless of what I do WMC will not die.

It's driving me bonkers! Can anyone help? Please!!
AutoRun can be disabled on an individual Windows machine with a (relatively) simple edit to the Registry. If you’re not experienced with Registry edits, be sure to make a back up first, so you can recover from any unexpected problems.
To disable AutoRun for all drive types — including CD and USB drives — search the Registry for values named NoDriveTypeAutoRun, and change the hex data for these values to FF. You can restrict your changes to the user account that’s currently active by changing only the value in the HKEY_CURRENT_USER registry hive. If you want to disable AutoRun for all user accounts, then use the “Find Next” tool under the Registry Editor’s “Edit” menu to cycle through all instances of the NoDriveTypeAutoRun value in the Registry, and change every key’s value to FF.
Some notes about this procedure
  • If editing the system Registry seems like more than you want to take on, you and your users can disable AutoRun on a case-by-case basis by simply holding the <Shift> key on the keyboard while inserting a disk or USB drive.
  • Disabling AutoRun via the Registry will not stop a removable device’s AutoRun instructions from executing when the user double-clicks on the device in Windows Explorer. It will keep AutoRun from activating automatically when the device is inserted, however.
  • The FF value for NoDriveTypeAutoRun will disable AutoRun for all devices. If you find this is overkill for your environment, you can reset hex value to 91 (the Windows XP default) or 95 (which Microsoft recommends as the value for these keys).
An Appendix for the advanced user
  • Since I know someone will point this out, it is possible to disable AutoRun using Group Policy, but that takes us beyond the scope of the helpdesk, and this article.
  • It also seems logical that one could disable AutoRun across the whole machine during system setup by adding a NoDriveTypeAutoRun value of FF in the HKEY_LOCAL_MACHINE hive (specifically in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer key) or in the HKEY_USERS\.DEFAULT\... node. Neither of these panned out in my testing; if you have different results, let me know in the Comments.
Stop the Windows AutoRun feature in its tracks | User Support | TechRepublic.com is where I got it from...
 


Celestra

Former Moderator
#3
Hi!!! There is an HP Forum entitled"Disable HP Quick Play Auto-start" (Business support forums HP) I would check with HP, they may have an easier way for you.
 


#4
Hi!!! There is an HP Forum entitled"Disable HP Quick Play Auto-start" (Business support forums HP) I would check with HP, they may have an easier way for you.
Why didn't I think of it so simply? I guess I just thought all you guys in here were brainiacs and I was trying to show off... lol...
 


#5
Thanks, but I don't want to disable Autorun completely, I just want to change the autorun behavior when a dvd is inserted.

I love the fact that autorun opens my burning software when I insert a blank dvd, or starts my audio program when I insert a CD.

I'd love for VLC to open when I insert a DVD, but Media Center opens no matter what I do.
 


#6
You can set WMC to not autostart when you start windows. That's what I did cuz it got on my nerves :eek:
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#8
You have to open media centre, hit settings, startup behaviour and untick 'start with windows'.. :D
 


Celestra

Former Moderator
#9
Hi!!! I think my computer is actually better behaved perhaps, than most other computers...... I don't seem to get these problems. Maybe you damaged the program in some way.
 


P

pjf

Guest
#10
yea
realy annoying when want to use power dvd
realy annoying trying to rip cds and MC starting up
MS are twats

control panel
auto play
dvd movie > take no action
cd > take no action

should work

if it dosent then something is fecked with your puter.
 


P

pjf

Guest
#11
contiued...

...dont forget to click save down in the right hand corner before you close the window, easily missed
 


B

bizarrotomek

Guest
#12
thankyou, that last one is the easiest!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.